summary refs log tree commit diff stats
path: root/system/marvin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/marvin.nix')
-rw-r--r--system/marvin.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/system/marvin.nix b/system/marvin.nix
new file mode 100644
index 00000000..0a7aceb5
--- /dev/null
+++ b/system/marvin.nix
@@ -0,0 +1,38 @@
+{ config, pkgs, ... }:
+
+{ imports = [
+    ./hardware-configuration.nix
+
+    ./modules/base.nix
+    ./modules/configuration/berlin.nix
+    ./modules/configuration/british-english.nix
+    ./modules/configuration/nix.nix
+    ./modules/configuration/user.nix
+    ./modules/development/base.nix
+    ./modules/development/javascript.nix
+    ./modules/development/lisp.nix
+    ./modules/hardware/adb.nix
+    ./modules/hardware/audio.nix
+    ./modules/hardware/qwerty.nix
+    ./modules/hardware/network-manager.nix
+    ./modules/hardware/nitrokey.nix
+    ./modules/hardware/systemd-boot.nix
+    ./modules/hardware/trackball.nix
+    ./modules/hardware/trezor.nix
+    ./modules/machines/x250.nix
+    ./modules/programs/accounting.nix
+    ./modules/programs/dotfiles.nix
+    ./modules/programs/i3.nix
+    ./modules/programs/infrastructure.nix
+    ./modules/programs/passwords.nix
+    ./modules/programs/shell.nix
+    ./modules/services/syncthing.nix
+  ];
+
+  networking = {
+    hostName = "marvin";
+    domain = "alanpearce.eu";
+  };
+
+  system.stateVersion = "18.09";
+}