summary refs log tree commit diff stats
path: root/system/linde.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/linde.nix')
-rw-r--r--system/linde.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/system/linde.nix b/system/linde.nix
index 48f8b8fe..ce7e073e 100644
--- a/system/linde.nix
+++ b/system/linde.nix
@@ -73,7 +73,6 @@ in
   environment.systemPackages = with pkgs; [
     htop
     lsof
-    gitMinimal
     powerdns
     sqlite-interactive
     knot-dns
@@ -980,6 +979,17 @@ in
     };
   };
 
+  programs.git = {
+    enable = true;
+    package = pkgs.gitMinimal;
+    config = {
+      advice = {
+        detachedHead = false;
+        mergeConflict = false;
+      };
+    };
+  };
+
   services.laminar = {
     enable = true;
     path = with pkgs; [