summary refs log tree commit diff stats
path: root/system/linde.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-06-22 18:09:11 +0200
committerAlan Pearce2024-06-22 18:09:11 +0200
commit918ab024b67faa112d6a7fe9f0e09e6ac73e1892 (patch)
treee2a8e1720b981e9a0b1cec62a2e5362cb1b25dc9 /system/linde.nix
parent51ee47682f841acadc3fa260af4e09b11de0daff (diff)
downloadnixfiles-918ab024b67faa112d6a7fe9f0e09e6ac73e1892.tar.lz
nixfiles-918ab024b67faa112d6a7fe9f0e09e6ac73e1892.tar.zst
nixfiles-918ab024b67faa112d6a7fe9f0e09e6ac73e1892.zip
linde: add minimal git configuration
Diffstat (limited to 'system/linde.nix')
-rw-r--r--system/linde.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/system/linde.nix b/system/linde.nix
index 48f8b8fe..ce7e073e 100644
--- a/system/linde.nix
+++ b/system/linde.nix
@@ -73,7 +73,6 @@ in
   environment.systemPackages = with pkgs; [
     htop
     lsof
-    gitMinimal
     powerdns
     sqlite-interactive
     knot-dns
@@ -980,6 +979,17 @@ in
     };
   };
 
+  programs.git = {
+    enable = true;
+    package = pkgs.gitMinimal;
+    config = {
+      advice = {
+        detachedHead = false;
+        mergeConflict = false;
+      };
+    };
+  };
+
   services.laminar = {
     enable = true;
     path = with pkgs; [