summary refs log tree commit diff stats
path: root/system/linde.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/linde.nix')
-rw-r--r--system/linde.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/system/linde.nix b/system/linde.nix
index 578b31c6..7fd8337a 100644
--- a/system/linde.nix
+++ b/system/linde.nix
@@ -480,7 +480,7 @@ in
     };
     acceptTerms = true;
     certs."alanpearce.eu" = {
-      extraDomainNames = [ "*.alanpearce.eu" "*.linde.alanpearce.eu" ];
+      domain = "*.alanpearce.eu";
     };
     certs."stats.alanpearce.eu" = {
       extraDomainNames = [ "*.stats.alanpearce.eu" ];
@@ -556,7 +556,6 @@ in
         };
         "searchix.alanpearce.eu" = {
           useACMEHost = "alanpearce.eu";
-          serverAliases = [ "searchix.linde.alanpearce.eu" ];
           extraConfig = ''
             reverse_proxy localhost:${toString config.services.searchix.settings.web.port} {
               health_uri /health
@@ -884,7 +883,7 @@ in
   services.searchix = {
     enable = true;
     environment = {
-      GOMEMLIMIT = "2000MiB";
+      GOMEMLIMIT = "1000MiB";
     };
     settings = {
       web =
@@ -956,6 +955,10 @@ in
       };
     };
   };
+  systemd.services.searchix.serviceConfig = {
+    MemoryHigh = "750M";
+    MemoryMax = "1G";
+  };
 
   programs.git = {
     enable = true;