summary refs log tree commit diff stats
path: root/system/linde.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/linde.nix')
-rw-r--r--system/linde.nix24
1 files changed, 14 insertions, 10 deletions
diff --git a/system/linde.nix b/system/linde.nix
index c0af9144..730e0a14 100644
--- a/system/linde.nix
+++ b/system/linde.nix
@@ -24,7 +24,6 @@ in
   imports =
     [
       <personal/modules/nixos/laminar.nix>
-      <personal/modules/nixos/goatcounter.nix>
       <home-manager/nixos>
       <agenix/modules/age.nix>
       <searchix/nix/modules>
@@ -352,15 +351,17 @@ in
 
   services.goatcounter = {
     enable = true;
-    listenAddress = "localhost";
+    address = "localhost";
     port = 8082;
-    package = (import <personal> { inherit pkgs; }).goatcounter;
-    settings = {
-      tls = "proxy";
-      websocket = true;
-      automigrate = true;
-      smtp = "smtp://localhost:25";
-    };
+    proxy = true;
+    extraArgs = [
+      "-db"
+      "sqlite3+db/goatcounter.sqlite3"
+      "-websocket"
+      "-automigrate"
+      "-smtp"
+      "smtp://localhost:25"
+    ];
   };
 
   services.powerdns =
@@ -805,7 +806,7 @@ in
             useACMEHost = "stats.alanpearce.eu";
             serverAliases = [ "*.stats.alanpearce.eu" ];
             extraConfig = ''
-              reverse_proxy ${srv.listenAddress}:${toString srv.port}
+              reverse_proxy ${srv.address}:${toString srv.port}
             '';
           };
         "go.alanpearce.eu" = {
@@ -943,6 +944,9 @@ in
     enable = true;
     initialClusterState = "existing";
     dataDir = "/var/lib/etcd"; # TODO backup
+    extraConf = {
+      AUTO_COMPACTION_RETENTION = "1h";
+    };
   };
 
   services.dex =