summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix21
1 files changed, 19 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index d2c4c458..b7d05d66 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,3 +1,20 @@
-{ system ? builtins.currentSystem }:
+let
+  inherit (import ./sources.nix) nixPath sources;
 
-(builtins.getFlake (toString ./.)).devShells.${system}.default
+  pkgs = import sources.nixpkgs { };
+in
+pkgs.mkShell
+{
+
+  name = "nixfiles-shell";
+
+  buildInputs = with pkgs; [
+    npins
+    (pkgs.callPackage "${sources.agenix}/pkgs/agenix.nix" { })
+    (import sources.home-manager { inherit pkgs; }).home-manager
+  ];
+
+  shellHook = ''
+    export NIX_PATH="${builtins.concatStringsSep ":" nixPath}";
+  '';
+}