summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 00000000..8b4f463c
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,26 @@
+let
+  sources = import ./nix/sources.nix;
+
+  nixpkgs = sources.nixpkgs;
+  pkgs = import nixpkgs { };
+  lib = import ./lib { inherit pkgs; };
+
+  nixPath = builtins.concatStringsSep ":" (lib.mkNixPath sources);
+in
+pkgs.mkShell
+{
+
+  name = "nixfiles-shell";
+
+  buildInputs = with pkgs; [
+    niv
+    deploy-rs
+    (pkgs.callPackage "${sources.agenix}/pkgs/agenix.nix" { })
+    (import sources.home-manager { inherit pkgs; }).home-manager
+  ];
+
+  shellHook = ''
+    export NIX_PATH="${nixPath}";
+  '';
+
+}