summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix14
1 files changed, 4 insertions, 10 deletions
diff --git a/shell.nix b/shell.nix
index 8b4f463c..b7d05d66 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,11 +1,7 @@
 let
-  sources = import ./nix/sources.nix;
+  inherit (import ./sources.nix) nixPath sources;
 
-  nixpkgs = sources.nixpkgs;
-  pkgs = import nixpkgs { };
-  lib = import ./lib { inherit pkgs; };
-
-  nixPath = builtins.concatStringsSep ":" (lib.mkNixPath sources);
+  pkgs = import sources.nixpkgs { };
 in
 pkgs.mkShell
 {
@@ -13,14 +9,12 @@ pkgs.mkShell
   name = "nixfiles-shell";
 
   buildInputs = with pkgs; [
-    niv
-    deploy-rs
+    npins
     (pkgs.callPackage "${sources.agenix}/pkgs/agenix.nix" { })
     (import sources.home-manager { inherit pkgs; }).home-manager
   ];
 
   shellHook = ''
-    export NIX_PATH="${nixPath}";
+    export NIX_PATH="${builtins.concatStringsSep ":" nixPath}";
   '';
-
 }