summary refs log tree commit diff stats
path: root/packages/htmlformat/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'packages/htmlformat/default.nix')
-rw-r--r--packages/htmlformat/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/htmlformat/default.nix b/packages/htmlformat/default.nix
new file mode 100644
index 00000000..aa124ee5
--- /dev/null
+++ b/packages/htmlformat/default.nix
@@ -0,0 +1,28 @@
+{ lib
+, buildGoModule
+, fetchFromGitHub
+}:
+
+buildGoModule rec {
+  pname = "htmlformat";
+  version = "unstable-2023-11-08";
+
+  src = fetchFromGitHub {
+    owner = "a-h";
+    repo = "htmlformat";
+    rev = "5bd994fe268e4d505a9793143fa85414c7d50887";
+    hash = "sha256-YSl9GsXhc0L2oKGZLwwjUtpe5W6ra6kk74zvQdsDCMU=";
+  };
+
+  vendorHash = "sha256-uVfh1pPhfj6AyQDqFd1EDWshuyDRvbMDZj3SN5tCS2w=";
+
+  ldflags = [ "-s" "-w" ];
+
+  meta = with lib; {
+    description = "Htmlformat";
+    homepage = "https://github.com/a-h/htmlformat";
+    license = licenses.mit;
+    maintainers = with maintainers; [ alanpearce ];
+    mainProgram = "htmlformat";
+  };
+}