summary refs log tree commit diff stats
path: root/overlays/extra-packages.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/extra-packages.nix')
-rw-r--r--overlays/extra-packages.nix17
1 files changed, 4 insertions, 13 deletions
diff --git a/overlays/extra-packages.nix b/overlays/extra-packages.nix
index 0bc408bf..76642078 100644
--- a/overlays/extra-packages.nix
+++ b/overlays/extra-packages.nix
@@ -13,17 +13,8 @@ self: super: {
         '';
       };
   });
-  enchant =
-    let
-      file = builtins.fetchurl {
-        url = "https://raw.githubusercontent.com/alanpearce/nixpkgs/7ee75d6aa9b088922b47b69c1912b2afe000ae52/pkgs/development/libraries/enchant/2.x.nix";
-        sha256 = "1y7h3fvp7ghcfb5v3h6riiv7z2bzgnxm0p696bbhfb0gwwv9q8aw";
-      };
-    in
-    super.callPackage file {
-      withHspell = false;
-      withAspell = false;
-
-      inherit (super.darwin.apple_sdk.frameworks) Cocoa;
-    };
+  enchant = super.personal.enchant-configurable.override {
+    withHspell = false;
+    withAspell = false;
+  };
 }