summary refs log tree commit diff stats
path: root/modules/services/xserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/xserver.nix')
-rw-r--r--modules/services/xserver.nix88
1 files changed, 88 insertions, 0 deletions
diff --git a/modules/services/xserver.nix b/modules/services/xserver.nix
new file mode 100644
index 00000000..2cef678b
--- /dev/null
+++ b/modules/services/xserver.nix
@@ -0,0 +1,88 @@
+{ config, pkgs, ... }:
+
+{ services.xserver = {
+    enable = true;
+    enableCtrlAltBackspace = true;
+    exportConfiguration = true;
+  };
+
+  services.dbus.socketActivated = true;
+
+  environment.sessionVariables = {
+    XCURSOR_PATH = [
+      "${config.system.path}/share/icons"
+      "$HOME/.icons"
+      "$HOME/.nix-profile/share/icons/"
+    ];
+  };
+
+  environment.systemPackages = with pkgs; [
+    xorg.xmodmap
+    xorg.xinit
+    xorg.xev
+    xorg.xdpyinfo
+    xclip
+    xfontsel
+
+    vanilla-dmz
+
+    hicolor_icon_theme
+    adapta-gtk-theme
+    flat-plat
+    paper-gtk-theme
+    paper-icon-theme
+
+    arc-icon-theme
+    tango-icon-theme
+
+    gtk-engine-murrine
+    gtk_engines
+  ];
+
+  fonts = {
+    enableFontDir = true;
+    enableDefaultFonts = true;
+    fontconfig = {
+      defaultFonts = {
+        monospace = [ "Liberation Mono" ];
+        sansSerif = [ "Liberation Sans" ];
+        serif = [ "Liberation Serif" ];
+      };
+      ultimate = {
+        enable = true;
+        # presets:
+        # ultimate1 ultimate2 ultimate3 ultimate4 ultimate5 osx windowsxp
+        preset = "ultimate3";
+      };
+    };
+    fonts = with pkgs; [
+      cantarell_fonts
+      carlito
+      dejavu_fonts
+      fantasque-sans-mono
+      fira
+      fira-code
+      fira-mono
+      font-droid
+      font-awesome-ttf
+      hack-font
+      liberation_ttf
+      mononoki
+      (nerdfonts.override {
+        withFont = "Monoid";
+      })
+      opensans-ttf
+      paratype-pt-mono
+      paratype-pt-sans
+      paratype-pt-serif
+      roboto
+      roboto-mono
+      roboto-slab
+      source-code-pro
+      source-sans-pro
+      source-serif-pro
+      terminus_font
+      xorg.fontxfree86type1
+    ];
+  };
+}