summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 58a0dcb8..ad11212e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -22,6 +22,7 @@
     , home-manager
     , nixpkgs
     , nix-index-database
+    , nixos-hardware
     , secrets
     , ...
     } @ attrs:
@@ -36,8 +37,15 @@
     {
       nixosConfigurations.prefect = nixpkgs.lib.nixosSystem {
         system = "x86_64-linux";
-        specialArgs = attrs;
-        modules = [ ./system/prefect.nix ];
+        modules = [
+          ./system/prefect.nix
+        ] ++ (with nixos-hardware.nixosModules; [
+          common-cpu-amd
+          common-cpu-amd-pstate
+          common-pc-ssd
+          common-pc
+          common-gpu-nvidia-nonprime
+        ]);
       };
       nixosConfigurations.nanopi = nixpkgs.lib.nixosSystem {
         system = aarch64LinuxSystem;