summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-04-09 21:06:38 +0200
committerAlan Pearce2024-04-09 21:06:38 +0200
commit8008288a089315b056c2d8907ce4a6d2b19a3cad (patch)
treef817241677241e813c36d17a5986b88920552ebb /flake.nix
parent10e41ec96f7792ad50ba162bf97ae189fd01623c (diff)
downloadnixfiles-8008288a089315b056c2d8907ce4a6d2b19a3cad.tar.lz
nixfiles-8008288a089315b056c2d8907ce4a6d2b19a3cad.tar.zst
nixfiles-8008288a089315b056c2d8907ce4a6d2b19a3cad.zip
hoist nixos-hardware imports to flake.nix
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 58a0dcb8..ad11212e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -22,6 +22,7 @@
     , home-manager
     , nixpkgs
     , nix-index-database
+    , nixos-hardware
     , secrets
     , ...
     } @ attrs:
@@ -36,8 +37,15 @@
     {
       nixosConfigurations.prefect = nixpkgs.lib.nixosSystem {
         system = "x86_64-linux";
-        specialArgs = attrs;
-        modules = [ ./system/prefect.nix ];
+        modules = [
+          ./system/prefect.nix
+        ] ++ (with nixos-hardware.nixosModules; [
+          common-cpu-amd
+          common-cpu-amd-pstate
+          common-pc-ssd
+          common-pc
+          common-gpu-nvidia-nonprime
+        ]);
       };
       nixosConfigurations.nanopi = nixpkgs.lib.nixosSystem {
         system = aarch64LinuxSystem;