summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 6329ef61..8e519a36 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,6 +2,8 @@
   inputs = {
     nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
     nixos-hardware.url = "github:NixOS/nixos-hardware";
+    nix-index-database.url = "github:Mic92/nix-index-database";
+    nix-index-database.inputs.nixpkgs.follows = "nixpkgs";
     darwin.url = "github:lnl7/nix-darwin/master";
     darwin.inputs.nixpkgs.follows = "nixpkgs";
     home-manager.url = "github:nix-community/home-manager";
@@ -19,6 +21,7 @@
     , emacs-overlay
     , home-manager
     , nixpkgs
+    , nix-index-database
     , secrets
     , ...
     } @ attrs:
@@ -46,6 +49,7 @@
         extraSpecialArgs = { inherit attrs; };
         modules = [
           ./user/mba.nix
+          nix-index-database.hmModules.nix-index
           (secrets + "/default.nix")
           (secrets + "/ssh.nix")
           ({ nixpkgs.overlays = [ emacs-overlay.overlay ]; })
@@ -56,6 +60,7 @@
         extraSpecialArgs = { inherit attrs; };
         modules = [
           ./user/prefect.nix
+          nix-index-database.hmModules.nix-index
           (secrets + "/default.nix")
           (secrets + "/ssh.nix")
           ({ nixpkgs.overlays = [ emacs-overlay.overlay ]; })
@@ -66,6 +71,7 @@
         extraSpecialArgs = { inherit attrs; };
         modules = [
           ./user/nanopi.nix
+          nix-index-database.hmModules.nix-index
           (secrets + "/default.nix")
         ];
       };
@@ -74,6 +80,7 @@
         extraSpecialArgs = { inherit attrs; };
         modules = [
           ./user/server.nix
+          nix-index-database.hmModules.nix-index
           (secrets + "/default.nix")
         ];
       };