summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 67f09c25..05939ac1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -14,6 +14,10 @@
     agenix.url = "github:ryantm/agenix";
     agenix.inputs.nixpkgs.follows = "nixpkgs";
     searchix.url = "git+https://git.alanpearce.eu/searchix";
+    golink = {
+      url = "github:tailscale/golink";
+      inputs.nixpkgs.follows = "nixpkgs-small";
+    };
   };
 
   outputs =
@@ -28,6 +32,7 @@
     , emacs-overlay
     , agenix
     , searchix
+    , golink
     , ...
     }:
     let
@@ -70,6 +75,7 @@
         modules = [
           agenix.nixosModules.default
           searchix.nixosModules.web
+          golink.nixosModules.default
           ./system/linde.nix
         ];
       };