summary refs log tree commit diff stats
path: root/user/settings/zsh.nix
diff options
context:
space:
mode:
authorAlan Pearce2019-10-09 15:46:19 +0200
committerAlan Pearce2019-10-09 15:46:19 +0200
commitf28f8a6d19d12030fda07e4524e0990c0418f520 (patch)
tree62bc36d4f891aca88fe14e6ceda5ec9241a0849f /user/settings/zsh.nix
parent880d11255a9164221a30be2bcfc9447c0629248b (diff)
downloadnixfiles-f28f8a6d19d12030fda07e4524e0990c0418f520.tar.lz
nixfiles-f28f8a6d19d12030fda07e4524e0990c0418f520.tar.zst
nixfiles-f28f8a6d19d12030fda07e4524e0990c0418f520.zip
zsh: add pnpm-based aliases
Diffstat (limited to 'user/settings/zsh.nix')
-rw-r--r--user/settings/zsh.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/user/settings/zsh.nix b/user/settings/zsh.nix
index d2feb988..17bf6f46 100644
--- a/user/settings/zsh.nix
+++ b/user/settings/zsh.nix
@@ -115,6 +115,23 @@ in
       gmup = "git mup";
       grup = "git rup";
 
+      p = "pnpm";
+      pi = "pnpm install";
+      pr = "pnpm run";
+      pmi = "pnpm multi install";
+      pmx = "pnpm multi exec";
+      pmr = "pnpm multi run";
+      pa = "pnpm install --save";
+      pad = "pnpm install --save-dev";
+      pd = "pnpm uninstall";
+      pou = "pnpm outdated";
+      pt = "pnpm test";
+      pmt = "pnpm multi test";
+      pup = "pnpm update";
+      ppr = "pnpm prune";
+      pli = "pnpm link";
+      pul = "pnpm unlink";
+
       hos = "home-manager switch";
       hon = "home-manager news";
       hoh = "home-manager-help";