summary refs log tree commit diff stats
path: root/user/settings/zsh.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-05-22 19:09:47 +0200
committerAlan Pearce2023-05-22 19:22:45 +0200
commit0b5545aec273e35baee25ee91949a0247e873801 (patch)
tree3c1da413fbab87ea2c209559ba59435f451b36df /user/settings/zsh.nix
parent4a4ab6d89a833895e26effa213fbc0e64b5e16ac (diff)
downloadnixfiles-0b5545aec273e35baee25ee91949a0247e873801.tar.lz
nixfiles-0b5545aec273e35baee25ee91949a0247e873801.tar.zst
nixfiles-0b5545aec273e35baee25ee91949a0247e873801.zip
zsh: replace agkozak prompt with powerlevel10k
Diffstat (limited to 'user/settings/zsh.nix')
-rw-r--r--user/settings/zsh.nix15
1 files changed, 11 insertions, 4 deletions
diff --git a/user/settings/zsh.nix b/user/settings/zsh.nix
index bb7b8974..3e60bada 100644
--- a/user/settings/zsh.nix
+++ b/user/settings/zsh.nix
@@ -69,10 +69,6 @@ in
 
     plugins = map mkZshPlugin [
       {
-        name = "agkozak-zsh-prompt";
-        src = pkgs.agkozak-zsh-prompt.src;
-      }
-      {
         name = "zsh-bd";
         file = "bd.plugin.zsh";
         src = pkgs.zsh-bd.src;
@@ -91,6 +87,11 @@ in
           sha256 = "08bjm1dd2mpv8rk8x6yvm6gj490rgimmiq7ln4jr5hik2k3mm82r";
         };
       }
+      {
+        name = "zsh-powerlevel10k";
+        src = pkgs.zsh-powerlevel10k.src;
+        file = "powerlevel10k.zsh-theme";
+      }
     ];
 
     shellAliases = {
@@ -203,6 +204,12 @@ in
       fi
     '';
 
+    initExtraFirst = ''
+      if [[ -r "${config.xdg.cacheHome}/p10k-instant-prompt-''${(%):-%n}.zsh" ]]; then
+        source "${config.xdg.cacheHome}/p10k-instant-prompt-''${(%):-%n}.zsh"
+      fi
+      typeset -g POWERLEVEL9K_DISABLE_CONFIGURATION_WIZARD=true
+    '';
     initExtra =
       ''
         typeset -T GHQ_ROOT ghq_root