summary refs log tree commit diff stats
path: root/user/settings/workstation.nix
diff options
context:
space:
mode:
authorAlan Pearce2025-03-20 08:10:15 +0100
committerAlan Pearce2025-03-20 08:10:15 +0100
commit1d2169d185c32bd2ed37c90412963ef3b310b3c9 (patch)
treee458f9d8240d0ce06eb0fba609434599bcca9e69 /user/settings/workstation.nix
parentdc87349ff98cd2f9af6f14eaa0281858dea05c7c (diff)
downloadnixfiles-1d2169d185c32bd2ed37c90412963ef3b310b3c9.tar.lz
nixfiles-1d2169d185c32bd2ed37c90412963ef3b310b3c9.tar.zst
nixfiles-1d2169d185c32bd2ed37c90412963ef3b310b3c9.zip
reduce packages on servers
Diffstat (limited to 'user/settings/workstation.nix')
-rw-r--r--user/settings/workstation.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/user/settings/workstation.nix b/user/settings/workstation.nix
new file mode 100644
index 00000000..8ecf1cfb
--- /dev/null
+++ b/user/settings/workstation.nix
@@ -0,0 +1,25 @@
+{ config
+, lib
+, pkgs
+, ...
+}: {
+  imports = [
+    <nix-index-database/home-manager-module.nix>
+    ./yazi.nix
+  ];
+
+  programs.nix-index-database.comma.enable = true;
+  programs.ripgrep.package = pkgs.ripgrep.override { withPCRE2 = true; };
+
+  home.packages = with pkgs; [
+    walk
+    nuspell
+  ] ++ (with pkgs.hunspellDicts; [
+    en-gb-large
+    de-de
+  ]);
+
+  home.shellAliases = {
+    wprop = "xprop | egrep '^WM_(CLASS|NAME|WINDOW_ROLE|TYPE)'";
+  };
+}