summary refs log tree commit diff stats
path: root/user/settings/tabnine.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-12-10 19:10:29 +0100
committerAlan Pearce2024-12-10 19:34:32 +0100
commitc98dc89219bdd965b6fd3aeb31fd33335add2e3b (patch)
tree5ffae08f09f97a89663cbdd3055a33c391822b89 /user/settings/tabnine.nix
parentf4406ad7fcaaaa342fdf425a2cda0e553388be02 (diff)
downloadnixfiles-c98dc89219bdd965b6fd3aeb31fd33335add2e3b.tar.lz
nixfiles-c98dc89219bdd965b6fd3aeb31fd33335add2e3b.tar.zst
nixfiles-c98dc89219bdd965b6fd3aeb31fd33335add2e3b.zip
Revert "remove tabnine and all related configuration"
This reverts commit 1065e1ba0fce3f7295ad6017b063f6324490aacd.
Diffstat (limited to 'user/settings/tabnine.nix')
-rw-r--r--user/settings/tabnine.nix124
1 files changed, 124 insertions, 0 deletions
diff --git a/user/settings/tabnine.nix b/user/settings/tabnine.nix
new file mode 100644
index 00000000..9502c68d
--- /dev/null
+++ b/user/settings/tabnine.nix
@@ -0,0 +1,124 @@
+{ config
+, pkgs
+, ...
+}: {
+  home.packages = with pkgs; [
+    tabnine
+  ];
+  programs.tabnine = {
+    enable = pkgs.lib.mkDefault true;
+    config = {
+      version = pkgs.tabnine.version;
+
+      api_base_url = null;
+      api_key = config.programs.tabnine.registrationKey;
+      beta_enabled = "No";
+      binary_update_interval_seconds = 365 * 24 * 3600;
+      cloud_whitelist = [ ];
+      creation_time = "2020-12-28T21:42:35.732522096Z";
+      deep_completions_work_mode = "LocalOnly";
+      disable_auto_update = true;
+      disable_local_when_using_battery = false;
+      enable_power_saving_mode = false;
+      enable_telemetry = false;
+      exclude_file_masks = true;
+      force_local_hub = true;
+      generation = 0;
+      guuid = null;
+      gusr.gcgdc = "0000000000000000000000000000000000000000000000000000000000000000";
+      has_git_repos = null;
+      heartbeat_interval_seconds = null;
+      hide_deep_information_message = false;
+      hide_promotional_message = true;
+      hosted_deep_completions_enabled = "Disabled";
+      ignore_all_lsp = false;
+      inline_suggestions_mode = true;
+      inline_suggestions_mode_clients = null;
+      last_service_level = null;
+      line_suggestions = true;
+      local_enabled = "Yes";
+      local_indexing = null;
+      local_model_size = null;
+      manually_selected_model = null;
+      model_hash_override = null;
+      num_of_suggestions = 5;
+      omit_prefix_suggestions = null;
+      onboarding = {
+        model_type = null;
+        skipped_login = true;
+        completed = true;
+      };
+      rate_limit_amount = null;
+      rate_limit_interval_seconds = null;
+      rlhf = null;
+      semantic_status = {
+        css = "Enabled";
+        dockerfile = "Enabled";
+        go = "Enabled";
+        haskell = "Enabled";
+        html = "Enabled";
+        javascript = "Enabled";
+        nix = "Enabled";
+        ruby = "Enabled";
+        scss = "Enabled";
+        typescript = "Enabled";
+        yaml = "Enabled";
+      };
+      snippets_enabled_v2 = true;
+      tabnine_cloud_certificate_domain = null;
+      tabnine_cloud_host = null;
+      tabnine_cloud_port = null;
+      tabnine_hub_port = null;
+      use_specialized_model_if_available = true;
+      user_understands_that_enabling_tabnine_cloud_sends_code_to_tabnine_servers = false;
+    };
+    lspConfig.language = {
+      typescript = {
+        command = "typescript-language-server";
+        args = [ "--stdio" ];
+      };
+      javascript = {
+        command = "javascript-typescript-stdio";
+        args = [ "--stdio" ];
+      };
+      css = {
+        command = "css-languageserver";
+        args = [ "--stdio" ];
+      };
+      scss = {
+        command = "css-languageserver";
+        args = [ "--stdio" ];
+      };
+      html = {
+        command = "html-languageserver";
+        args = [ "--stdio" ];
+      };
+      nix = {
+        command = "nil";
+        args = [ "--stdio" ];
+      };
+      dockerfile = {
+        command = "docker-langserver";
+        args = [ "--stdio" ];
+      };
+      ruby = {
+        command = "solargraph";
+        args = [ "stdio" ];
+      };
+      yaml = {
+        command = "yaml-language-server";
+        args = [ "--stdio" ];
+      };
+      haskell = {
+        command = "hie";
+        args = [ "--stdio" ];
+      };
+      go = {
+        command = "gopls";
+        args = [
+          "serve"
+        ];
+      };
+    };
+  };
+}