summary refs log tree commit diff stats
path: root/user/settings/tabnine.nix
diff options
context:
space:
mode:
authorAlan Pearce2022-10-16 23:49:18 +0200
committerAlan Pearce2022-10-16 23:56:07 +0200
commit05dd85210e465caa44ef7254f2781b2d12ba2882 (patch)
tree85ccc720e339dd5ca8d7eb3ce6a3488c78675235 /user/settings/tabnine.nix
parent472dbbdbb246cf3d8ce3a5c3c6cefaa07b7589df (diff)
downloadnixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.lz
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.zst
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.zip
Reformat files with alejandra
Diffstat (limited to 'user/settings/tabnine.nix')
-rw-r--r--user/settings/tabnine.nix29
1 files changed, 16 insertions, 13 deletions
diff --git a/user/settings/tabnine.nix b/user/settings/tabnine.nix
index dab2273b..61cbf29c 100644
--- a/user/settings/tabnine.nix
+++ b/user/settings/tabnine.nix
@@ -1,7 +1,9 @@
-{ config, pkgs, ... }:
-
 {
-  imports = [ ../modules/tabnine.nix ];
+  config,
+  pkgs,
+  ...
+}: {
+  imports = [../modules/tabnine.nix];
   home.packages = with pkgs; [
     tabnine
   ];
@@ -26,7 +28,7 @@
       tabnine_cloud_certificate_domain = null;
       tabnine_cloud_host = null;
       tabnine_cloud_port = null;
-      cloud_whitelist = [ ];
+      cloud_whitelist = [];
       api_key = null;
       api_key_service_level = null;
       api_base_url = null;
@@ -44,40 +46,41 @@
     lspConfig = {
       "language.typescript" = {
         command = "typescript-language-server";
-        args = [ "--stdio" ];
+        args = ["--stdio"];
       };
       "language.javascript" = {
         command = "javascript-typescript-stdio";
-        args = [ "--stdio" ];
+        args = ["--stdio"];
       };
       "language.css" = {
         command = "css-languageserver";
-        args = [ "--stdio" ];
+        args = ["--stdio"];
       };
       "language.scss" = {
         command = "css-languageserver";
-        args = [ "--stdio" ];
+        args = ["--stdio"];
       };
       "language.html" = {
         command = "html-languageserver";
-        args = [ "--stdio" ];
+        args = ["--stdio"];
       };
       "language.dockerfile" = {
         command = "docker-langserver";
-        args = [ "--stdio" ];
+        args = ["--stdio"];
       };
       "language.yaml" = {
         command = "yaml-language-server";
-        args = [ "--stdio" ];
+        args = ["--stdio"];
       };
       "language.haskell" = {
         command = "hie";
-        args = [ "--stdio" ];
+        args = ["--stdio"];
       };
       "language.go" = {
         command = "go-langserver";
         args = [
-          "-mode" "stdio"
+          "-mode"
+          "stdio"
           "-gocodecompletion"
         ];
       };