summary refs log tree commit diff stats
path: root/user/settings/i3.nix
diff options
context:
space:
mode:
authorAlan Pearce2022-10-16 23:49:18 +0200
committerAlan Pearce2022-10-16 23:56:07 +0200
commit05dd85210e465caa44ef7254f2781b2d12ba2882 (patch)
tree85ccc720e339dd5ca8d7eb3ce6a3488c78675235 /user/settings/i3.nix
parent472dbbdbb246cf3d8ce3a5c3c6cefaa07b7589df (diff)
downloadnixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.lz
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.zst
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.zip
Reformat files with alejandra
Diffstat (limited to 'user/settings/i3.nix')
-rw-r--r--user/settings/i3.nix70
1 files changed, 49 insertions, 21 deletions
diff --git a/user/settings/i3.nix b/user/settings/i3.nix
index cb71baf3..5443d1d6 100644
--- a/user/settings/i3.nix
+++ b/user/settings/i3.nix
@@ -1,6 +1,9 @@
-{ config, pkgs, lib, ... }:
-
 {
+  config,
+  pkgs,
+  lib,
+  ...
+}: {
   xdg.configFile.i3status = {
     recursive = true;
     source = ../i3/i3status;
@@ -9,32 +12,58 @@
     mod = "Mod4";
     mode_system = "System (l) lock, (e) logout, (s) suspend, (h) hibernate, (r) reboot, (Shift+s) shutdown";
     locker = "${pkgs.xautolock}/bin/xautolock -locknow";
-  in
-  {
+  in {
     enable = true;
     config = {
       modifier = mod;
       assigns = {
-        "1" = [{ class = "^Ripcord$"; }];
-        "3" = [{ class = "^Firefox Developer Edition$"; }];
-        "8" = [{ class = "^Emacs$"; }];
-        "9" = [{ class = "\.exe$"; }];
-        "10" = [{ class = "^Barrier$"; }];
+        "1" = [{class = "^Ripcord$";}];
+        "3" = [{class = "^Firefox Developer Edition$";}];
+        "8" = [{class = "^Emacs$";}];
+        "9" = [{class = "\.exe$";}];
+        "10" = [{class = "^Barrier$";}];
       };
       floating = {
         criteria = [
-          { class = "Pinentry$"; }
+          {class = "Pinentry$";}
           # https://github.com/ValveSoftware/steam-for-linux/issues/1040
-          { class = "^Steam$"; title = "^Friends$"; }
-          { class = "^Steam$"; title = "Steam - News"; }
-          { class = "^Steam$"; title = ".* - Chat"; }
-          { class = "^Steam$"; title = "^Settings$"; }
-          { class = "^Steam$"; title = ".* - event started"; }
-          { class = "^Steam$"; title = ".* CD key"; }
-          { class = "^Steam$"; title = "^Steam - Self Updater$"; }
-          { class = "^Steam$"; title = "^Screenshot Uploader$"; }
-          { class = "^Steam$"; title = "^Steam Guard - Computer Authorization Required$"; }
-          { title = "^Steam Keyboard$"; }
+          {
+            class = "^Steam$";
+            title = "^Friends$";
+          }
+          {
+            class = "^Steam$";
+            title = "Steam - News";
+          }
+          {
+            class = "^Steam$";
+            title = ".* - Chat";
+          }
+          {
+            class = "^Steam$";
+            title = "^Settings$";
+          }
+          {
+            class = "^Steam$";
+            title = ".* - event started";
+          }
+          {
+            class = "^Steam$";
+            title = ".* CD key";
+          }
+          {
+            class = "^Steam$";
+            title = "^Steam - Self Updater$";
+          }
+          {
+            class = "^Steam$";
+            title = "^Screenshot Uploader$";
+          }
+          {
+            class = "^Steam$";
+            title = "^Steam Guard - Computer Authorization Required$";
+          }
+          {title = "^Steam Keyboard$";}
         ];
       };
       window = {
@@ -85,7 +114,6 @@
         "${mod}+Shift+9" = "move container to workspace 9";
         "${mod}+Shift+0" = "move container to workspace 10";
 
-
         # move workspace
         "${mod}+Mod1+h" = "move workspace to output left";
         "${mod}+Mod1+j" = "move workspace to output down";