summary refs log tree commit diff stats
path: root/user/settings/fish.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-08-25 05:55:57 +0200
committerAlan Pearce2023-08-25 05:55:57 +0200
commit13735084caa94892bba79bdb440556bbebfb4d53 (patch)
tree7c0fcfa173aaf2324d9e9c2237aa4c6c5ed3479e /user/settings/fish.nix
parentbd3083be8b43cb2e2e10a7456551cfc5fb0fde11 (diff)
downloadnixfiles-13735084caa94892bba79bdb440556bbebfb4d53.tar.lz
nixfiles-13735084caa94892bba79bdb440556bbebfb4d53.tar.zst
nixfiles-13735084caa94892bba79bdb440556bbebfb4d53.zip
fish: fix nix evaluation error
Diffstat (limited to 'user/settings/fish.nix')
-rw-r--r--user/settings/fish.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/user/settings/fish.nix b/user/settings/fish.nix
index 4bee970f..be68432e 100644
--- a/user/settings/fish.nix
+++ b/user/settings/fish.nix
@@ -1,4 +1,5 @@
 { pkgs
+, lib
 , ...
 }: {
   programs.fish = {
@@ -43,8 +44,8 @@
       end
     '';
     shellAliases = {
-      hist-freq-lines = "history | sort | uniq -c | sort -gr | head -n100 | less";
-      hist-freq-commands = "history | cut -d' ' -f 1 | sort | uniq -c | sort -gr | head -n100 | less";
+      hist-freq-lines = lib.mkForce "history | sort | uniq -c | sort -gr | head -n100 | less";
+      hist-freq-commands = lib.mkForce "history | cut -d' ' -f 1 | sort | uniq -c | sort -gr | head -n100 | less";
     };
     functions = {
       ds = "du -hd1 $argv[1] | sort -h";