summary refs log tree commit diff stats
path: root/user/settings/emacs.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-25 05:39:51 +0200
committerAlan Pearce2024-05-25 05:39:51 +0200
commitdaa739e6f5f1754d9861924018569131beb3bf88 (patch)
tree1c7088802ed2c7d53065276be941e8eb6c589020 /user/settings/emacs.nix
parentb09a6d6d7894650331ec1e26de9daacac74cb3d4 (diff)
downloadnixfiles-daa739e6f5f1754d9861924018569131beb3bf88.tar.lz
nixfiles-daa739e6f5f1754d9861924018569131beb3bf88.tar.zst
nixfiles-daa739e6f5f1754d9861924018569131beb3bf88.zip
Emacs: set eln cache directory properly
1. It needs to be set in early-init.el
2. It should not be the last value of `native-comp-eln-load-path`, as
that is expected to be a system directory
Diffstat (limited to 'user/settings/emacs.nix')
-rw-r--r--user/settings/emacs.nix5
1 files changed, 0 insertions, 5 deletions
diff --git a/user/settings/emacs.nix b/user/settings/emacs.nix
index 5ed9eb4f..7f681bd1 100644
--- a/user/settings/emacs.nix
+++ b/user/settings/emacs.nix
@@ -6,8 +6,6 @@
 let
   inherit (pkgs) stdenv;
 
-  nativeCompileDirectory = "${config.xdg.cacheHome}/emacs/native-compile/";
-
   editorScript = pkgs.writeScriptBin "edit" ''
     #!${pkgs.runtimeShell}
     if [ -z "$1" ]; then
@@ -199,9 +197,6 @@ in
     extraConfig = ''
       (with-eval-after-load 'editorconfig
         (defvar editorconfig-exec-path "${pkgs.editorconfig-core-c}/bin/editorconfig"))
-      (when (featurep 'native-compile)
-        (defvar native-compile-target-directory "${nativeCompileDirectory}")
-        (add-to-list 'native-comp-eln-load-path "${nativeCompileDirectory}" :append))
     '' + lib.optionalString stdenv.isDarwin ''
       (with-eval-after-load 'files
         (defvar insert-directory-program "${pkgs.coreutils-prefixed}/bin/gls"))