summary refs log tree commit diff stats
path: root/user/settings/emacs.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-16 18:01:16 +0200
committerAlan Pearce2024-05-16 18:01:42 +0200
commit18ed3572ae444dbbb8e64adbc29639290cbadb21 (patch)
treea156c987b66f54b1e3c2d22cef8531181ab37b83 /user/settings/emacs.nix
parentf134b702150f49f8ecaac7d3a1948422fd182592 (diff)
downloadnixfiles-18ed3572ae444dbbb8e64adbc29639290cbadb21.tar.lz
nixfiles-18ed3572ae444dbbb8e64adbc29639290cbadb21.tar.zst
nixfiles-18ed3572ae444dbbb8e64adbc29639290cbadb21.zip
emacs: use lsp-mode for go to support secondary language server
Diffstat (limited to 'user/settings/emacs.nix')
-rw-r--r--user/settings/emacs.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/user/settings/emacs.nix b/user/settings/emacs.nix
index 722a7a6d..9615f9d1 100644
--- a/user/settings/emacs.nix
+++ b/user/settings/emacs.nix
@@ -127,6 +127,7 @@ in
         justl
         kind-icon
         lua-mode
+        lsp-mode
         lispyville
         magit
         markdown-mode
@@ -155,7 +156,7 @@ in
         ws-butler
         which-key
       ]);
-    overrides = self: super: rec {
+    overrides = self: super: {
       apheleia = self.melpaPackages.apheleia.overrideAttrs
         (old: {
           patchPhase = ''
@@ -163,8 +164,12 @@ in
               --replace-fail '"prettier"' '"prettierd"'
           '';
         });
+      lsp-mode = self.melpaPackages.lsp-mode.overrideAttrs {
+        LSP_USE_PLISTS = "true"; # sync with below
+      };
     };
     extraConfig = ''
+      (setenv "LSP_USE_PLISTS" "true") ; sync with above
       (with-eval-after-load 'editorconfig
         (setq editorconfig-exec-path "${pkgs.editorconfig-core-c}/bin/editorconfig"))
       (when (featurep 'native-compile)