summary refs log tree commit diff stats
path: root/user/settings/emacs.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-06-24 20:00:02 +0200
committerAlan Pearce2023-06-24 20:00:02 +0200
commit05367ba280ad0318a7438d08b64b9268e5f97bc1 (patch)
treee25a88b07d46f0277a14a32236a9dc40081d0c5d /user/settings/emacs.nix
parent5df8596e63a9946ea84d1d34371c6f31386527be (diff)
downloadnixfiles-05367ba280ad0318a7438d08b64b9268e5f97bc1.tar.lz
nixfiles-05367ba280ad0318a7438d08b64b9268e5f97bc1.tar.zst
nixfiles-05367ba280ad0318a7438d08b64b9268e5f97bc1.zip
Emacs: fix override of consult-ghq
Diffstat (limited to 'user/settings/emacs.nix')
-rw-r--r--user/settings/emacs.nix38
1 files changed, 15 insertions, 23 deletions
diff --git a/user/settings/emacs.nix b/user/settings/emacs.nix
index 872d724a..db83453f 100644
--- a/user/settings/emacs.nix
+++ b/user/settings/emacs.nix
@@ -45,31 +45,23 @@ in
     ../modules/eshell.nix
   ];
 
-  nixpkgs.overlays = [
-    (self: super: {
-      emacsPackagesFor = emacs:
-        (super.emacsPackagesFor emacs).overrideScope' (
-          eself: esuper:
-            (
-              {
-                consult-ghq = esuper.consult-ghq.overrideAttrs
-                  (oldAttrs: {
-                    src = pkgs.fetchFromGitHub {
-                      owner = "alanpearce";
-                      repo = "consult-ghq";
-                      rev = "3a0b366ef2e066c0d941a19d22d5a23d7f778535";
-                      sha256 = "0v7z61nx6xyhxbqkjangqrnay7pp74w4m90wfb29l99p1wkxqbzx";
-                    };
-                  });
-              }
-            )
-        );
-    })
-  ];
-
   programs.emacs = {
     enable = true;
     package = lib.mkDefault (pkgs.emacs.override { withGTK3 = true; });
+    overrides = self: super: (
+      {
+        consult-ghq = super.consult-ghq.overrideAttrs
+          (oldAttrs: {
+            src = pkgs.fetchFromGitHub {
+              owner = "alanpearce";
+              repo = "consult-ghq";
+              rev = "3a0b366ef2e066c0d941a19d22d5a23d7f778535";
+              sha256 = "0v7z61nx6xyhxbqkjangqrnay7pp74w4m90wfb29l99p1wkxqbzx";
+            };
+          });
+      }
+    );
+
     eshell = {
       aliases = {
         pk = "eshell-up-pk $1";
@@ -113,7 +105,7 @@ in
         company-shell
         company-tabnine
         consult
-        consult-ghq # own override
+        consult-ghq
         consult-eglot
         crux
         dired-git-info