summary refs log tree commit diff stats
path: root/user/settings/darwin.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-08-22 19:10:12 +0200
committerAlan Pearce2023-08-22 19:10:12 +0200
commitf8f5398d96b34adb178b9b73ee8228e78eddd329 (patch)
tree5f64f2d37ada0e7e96a74f35b91b13b7dc626171 /user/settings/darwin.nix
parent4a22fe0cf6b7c54d67dbf7c45d82fb8d7f330bbf (diff)
downloadnixfiles-f8f5398d96b34adb178b9b73ee8228e78eddd329.tar.lz
nixfiles-f8f5398d96b34adb178b9b73ee8228e78eddd329.tar.zst
nixfiles-f8f5398d96b34adb178b9b73ee8228e78eddd329.zip
Remove zsh config
Diffstat (limited to 'user/settings/darwin.nix')
-rw-r--r--user/settings/darwin.nix43
1 files changed, 0 insertions, 43 deletions
diff --git a/user/settings/darwin.nix b/user/settings/darwin.nix
index adb69b9f..df12f1fc 100644
--- a/user/settings/darwin.nix
+++ b/user/settings/darwin.nix
@@ -3,43 +3,7 @@
 , lib
 , ...
 }: {
-  nixpkgs.overlays = [
-    (self: super: {
-      darwin-zsh-completions =
-        super.runCommand "darwin-zsh-completions-0.0.0"
-          {
-            preferLocalBuild = true;
-          } ''
-          mkdir -p $out/share/zsh/site-functions
-          cat <<-'EOF' > $out/share/zsh/site-functions/_darwin-rebuild
-          #compdef darwin-rebuild
-          #autoload
-          _nix-common-options
-          local -a _1st_arguments
-          _1st_arguments=(
-          'switch:Build, activate, and update the current generation'\
-          'build:Build without activating or updating the current generation'\
-          'check:Build and run the activation sanity checks'\
-          'changelog:Show most recent entries in the changelog'\
-          )
-          _arguments \
-          '--list-generations[Print a list of all generations in the active profile]'\
-          '--rollback[Roll back to the previous configuration]'\
-          {--switch-generation,-G}'[Activate specified generation]'\
-          '(--profile-name -p)'{--profile-name,-p}'[Profile to use to track current and previous system configurations]:Profile:_nix_profiles'\
-          '1:: :->subcmds' && return 0
-          case $state in
-          subcmds)
-          _describe -t commands 'darwin-rebuild subcommands' _1st_arguments
-          ;;
-          esac
-          EOF
-        '';
-    })
-
-  ];
   home.packages = with pkgs; [
-    darwin-zsh-completions
     darwin.trash
   ];
 
@@ -134,9 +98,6 @@
     };
   };
 
-  programs.zsh.dirHashes = {
-    icloud = "$HOME/Library/Mobile\ Documents/com~apple~CloudDocs";
-  };
   home.shellAliases = {
     rb = "darwin-rebuild";
     rbs = "darwin-rebuild switch --flake $(ghq list -p nixfiles)";
@@ -153,10 +114,6 @@
     IdentityAgent ${config.home.sessionVariables.SSH_AUTH_SOCK}
   '';
 
-  programs.zsh.envExtra = ''
-    SHELL_SESSIONS_DISABLE=1
-    path+=($HOME/Library/Python/3.9/bin)
-  '';
   home.activation.linkStrongboxSSHAgentSocket = lib.hm.dag.entryAfter [ "writeBoundary" ] ''
     if [[ ! -d ~/.strongbox ]]
     then