summary refs log tree commit diff stats
path: root/user/settings/darwin.nix
diff options
context:
space:
mode:
authorAlan Pearce2022-10-14 18:01:11 +0200
committerAlan Pearce2022-10-14 18:01:18 +0200
commit6e34ca8bda9cddcce1ea73f73b883a3ec8358678 (patch)
tree8c244fa50f03640b663b07dbe5ef74bc67d80833 /user/settings/darwin.nix
parentbf435de812836511a9ba580a66acf3cd235cd15c (diff)
downloadnixfiles-6e34ca8bda9cddcce1ea73f73b883a3ec8358678.tar.lz
nixfiles-6e34ca8bda9cddcce1ea73f73b883a3ec8358678.tar.zst
nixfiles-6e34ca8bda9cddcce1ea73f73b883a3ec8358678.zip
Reformat nix files
Diffstat (limited to 'user/settings/darwin.nix')
-rw-r--r--user/settings/darwin.nix64
1 files changed, 30 insertions, 34 deletions
diff --git a/user/settings/darwin.nix b/user/settings/darwin.nix
index ab7afe15..50d84464 100644
--- a/user/settings/darwin.nix
+++ b/user/settings/darwin.nix
@@ -3,41 +3,37 @@
 {
   nixpkgs.overlays = [
     (self: super: {
-      darwin-zsh-completions = super.runCommand "darwin-zsh-completions-0.0.0"
-        { preferLocalBuild = true; }
-        ''
-          mkdir -p $out/share/zsh/site-functions
-          cat <<-'EOF' > $out/share/zsh/site-functions/_darwin-rebuild
-          #compdef darwin-rebuild
-          #autoload
-          _nix-common-options
-          local -a _1st_arguments
-          _1st_arguments=(
-            'switch:Build, activate, and update the current generation'\
-            'build:Build without activating or updating the current generation'\
-            'check:Build and run the activation sanity checks'\
-            'changelog:Show most recent entries in the changelog'\
-          )
-          _arguments \
-            '--list-generations[Print a list of all generations in the active profile]'\
-            '--rollback[Roll back to the previous configuration]'\
-            {--switch-generation,-G}'[Activate specified generation]'\
-            '(--profile-name -p)'{--profile-name,-p}'[Profile to use to track current and previous system configurations]:Profile:_nix_profiles'\
-            '1:: :->subcmds' && return 0
-          case $state in
-            subcmds)
-              _describe -t commands 'darwin-rebuild subcommands' _1st_arguments
-            ;;
-          esac
-          EOF
-        '';
-      })
-  ];
-  home.packages = with pkgs; [
-      aspell
-      aspellDicts.en
-      darwin-zsh-completions
+      darwin-zsh-completions = super.runCommand "darwin-zsh-completions-0.0.0" {
+        preferLocalBuild = true;
+      } ''
+        mkdir -p $out/share/zsh/site-functions
+        cat <<-'EOF' > $out/share/zsh/site-functions/_darwin-rebuild
+        #compdef darwin-rebuild
+        #autoload
+        _nix-common-options
+        local -a _1st_arguments
+        _1st_arguments=(
+        'switch:Build, activate, and update the current generation'\
+        'build:Build without activating or updating the current generation'\
+        'check:Build and run the activation sanity checks'\
+        'changelog:Show most recent entries in the changelog'\
+        )
+        _arguments \
+        '--list-generations[Print a list of all generations in the active profile]'\
+        '--rollback[Roll back to the previous configuration]'\
+        {--switch-generation,-G}'[Activate specified generation]'\
+        '(--profile-name -p)'{--profile-name,-p}'[Profile to use to track current and previous system configurations]:Profile:_nix_profiles'\
+        '1:: :->subcmds' && return 0
+        case $state in
+        subcmds)
+        _describe -t commands 'darwin-rebuild subcommands' _1st_arguments
+        ;;
+        esac
+        EOF
+      '';
+    })
   ];
+  home.packages = with pkgs; [ aspell aspellDicts.en darwin-zsh-completions ];
 
   programs.emacs.package = pkgs.emacsMacport;