summary refs log tree commit diff stats
path: root/user/settings/darwin.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-04-02 20:27:15 +0200
committerAlan Pearce2023-04-02 20:27:15 +0200
commit14e573db264debf99046142ce9a72f41ccdf3baa (patch)
tree67502a14cfee32b9ab9c3c48cb344fe0783be87c /user/settings/darwin.nix
parent74faf88c4f59a235c598cc9fdc76b2e07b9e4c39 (diff)
downloadnixfiles-14e573db264debf99046142ce9a72f41ccdf3baa.tar.lz
nixfiles-14e573db264debf99046142ce9a72f41ccdf3baa.tar.zst
nixfiles-14e573db264debf99046142ce9a72f41ccdf3baa.zip
darwin: let GUI applications know about XDG_CACHE_HOME
Diffstat (limited to 'user/settings/darwin.nix')
-rw-r--r--user/settings/darwin.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/user/settings/darwin.nix b/user/settings/darwin.nix
index fb6cf196..2ca4ddf6 100644
--- a/user/settings/darwin.nix
+++ b/user/settings/darwin.nix
@@ -63,6 +63,21 @@
         LowPriorityBackgroundIO = true;
       };
     };
+    set-xdg-cache-home = {
+      enable = true;
+
+      config = {
+        ProgramArguments = [
+          "/bin/launchctl"
+          "setenv"
+          "XDG_CACHE_HOME"
+          config.xdg.cacheHome
+        ];
+        RunAtLoad = true;
+        StandardErrorPath = "/dev/null";
+        StandardOutputPath = "/dev/null";
+      };
+    };
   };
 
   programs.zsh.shellAliases = {