summary refs log tree commit diff stats
path: root/user/packages/tabnine-capf.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-04-23 22:38:24 +0200
committerAlan Pearce2023-04-30 19:38:15 +0200
commitdb728f16997c045162041920e359666dc413ea00 (patch)
tree6b55c582378c527dcef8093adf701baa08f0fa0f /user/packages/tabnine-capf.nix
parent215ad38f56fd49904c20af0d38233fc61d4d51ba (diff)
downloadnixfiles-db728f16997c045162041920e359666dc413ea00.tar.lz
nixfiles-db728f16997c045162041920e359666dc413ea00.tar.zst
nixfiles-db728f16997c045162041920e359666dc413ea00.zip
emacs: replace company-tabnine with tabnine-capf
Diffstat (limited to 'user/packages/tabnine-capf.nix')
-rw-r--r--user/packages/tabnine-capf.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/user/packages/tabnine-capf.nix b/user/packages/tabnine-capf.nix
new file mode 100644
index 00000000..94e730ea
--- /dev/null
+++ b/user/packages/tabnine-capf.nix
@@ -0,0 +1,47 @@
+{ eself
+, fetchFromGitHub
+, emacs
+, gcc
+, lib
+, writeText
+, unstableGitUpdater
+, ...
+}:
+let
+  rev = "a55cefee20ea94747b12068a1d4b64b0decf37eb";
+in
+eself.trivialBuild {
+  ename = "tabnine-capf";
+  pname = "tabnine-capf";
+  version = "0.0.1+unstable=2023-04-23";
+
+  src = fetchFromGitHub {
+    owner = "50ways2sayhard";
+    repo = "tabnine-capf";
+    inherit rev;
+    sha256 = "14n5xklm9cpkn04crvx7mlykk48w2j2w5vcf6ipfj84dhpiyzh0j";
+  };
+
+  packageRequires = with eself; [ dash s ];
+
+  buildInputs = [ emacs gcc ];
+
+  buildPhase = ''
+    runHook preBuild
+    emacs -L . --batch --funcall batch-byte-compile *.el
+    runHook postBuild
+  '';
+
+  recipe = writeText "recipe" ''
+    (tabnine-capf :repo "50ways2sayhard/tabnine-capf" :fetcher github)
+  '';
+
+  passthru.updateScript = unstableGitUpdater { };
+
+  meta = with lib; {
+    description = "A capf version of company-tabnine";
+    homepage = "https://github.com/50ways2sayhard/tabnine-capf";
+    license = licenses.mit;
+    inherit (emacs.meta) platforms;
+  };
+}