summary refs log tree commit diff stats
path: root/user/packages/node2nix/node-packages.nix
diff options
context:
space:
mode:
authorAlan Pearce2022-10-16 23:49:18 +0200
committerAlan Pearce2022-10-16 23:56:07 +0200
commit05dd85210e465caa44ef7254f2781b2d12ba2882 (patch)
tree85ccc720e339dd5ca8d7eb3ce6a3488c78675235 /user/packages/node2nix/node-packages.nix
parent472dbbdbb246cf3d8ce3a5c3c6cefaa07b7589df (diff)
downloadnixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.lz
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.zst
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.zip
Reformat files with alejandra
Diffstat (limited to 'user/packages/node2nix/node-packages.nix')
-rw-r--r--user/packages/node2nix/node-packages.nix180
1 files changed, 99 insertions, 81 deletions
diff --git a/user/packages/node2nix/node-packages.nix b/user/packages/node2nix/node-packages.nix
index 0d449525..64748fe5 100644
--- a/user/packages/node2nix/node-packages.nix
+++ b/user/packages/node2nix/node-packages.nix
@@ -1,8 +1,13 @@
 # This file has been generated by node2nix 1.11.1. Do not edit!
-
-{nodeEnv, fetchurl, fetchgit, nix-gitignore, stdenv, lib, globalBuildInputs ? []}:
-
-let
+{
+  nodeEnv,
+  fetchurl,
+  fetchgit,
+  nix-gitignore,
+  stdenv,
+  lib,
+  globalBuildInputs ? [],
+}: let
   sources = {
     "abort-controller-3.0.0" = {
       name = "abort-controller";
@@ -1058,8 +1063,7 @@ let
       };
     };
   };
-in
-{
+in {
   "pnpm-7.12" = nodeEnv.buildNodePackage {
     name = "pnpm";
     packageName = "pnpm";
@@ -1102,11 +1106,12 @@ in
       sources."fast-safe-stringify-2.1.1"
       sources."fs.realpath-1.0.0"
       sources."glob-8.0.3"
-      (sources."help-me-4.1.0" // {
-        dependencies = [
-          sources."readable-stream-3.6.0"
-        ];
-      })
+      (sources."help-me-4.1.0"
+        // {
+          dependencies = [
+            sources."readable-stream-3.6.0"
+          ];
+        })
       sources."ieee754-1.2.1"
       sources."inflight-1.0.6"
       sources."inherits-2.0.4"
@@ -1183,16 +1188,18 @@ in
       sha512 = "2kzWnV1QM6KBetziCAkCf8BJdnDX2CwiAr4yhvOsiQpaNJcMzwMsJTX/gTHz58yQg0dV5uwPsIyBlvyIfl30rg==";
     };
     dependencies = [
-      (sources."asn1.js-5.4.1" // {
-        dependencies = [
-          sources."bn.js-4.12.0"
-        ];
-      })
-      (sources."assert-1.5.0" // {
-        dependencies = [
-          sources."util-0.10.3"
-        ];
-      })
+      (sources."asn1.js-5.4.1"
+        // {
+          dependencies = [
+            sources."bn.js-4.12.0"
+          ];
+        })
+      (sources."assert-1.5.0"
+        // {
+          dependencies = [
+            sources."util-0.10.3"
+          ];
+        })
       sources."base64-js-1.5.1"
       sources."bn.js-5.2.1"
       sources."brorand-1.1.0"
@@ -1200,12 +1207,13 @@ in
       sources."browserify-cipher-1.0.1"
       sources."browserify-des-1.0.2"
       sources."browserify-rsa-4.1.0"
-      (sources."browserify-sign-4.2.1" // {
-        dependencies = [
-          sources."inherits-2.0.4"
-          sources."readable-stream-3.6.0"
-        ];
-      })
+      (sources."browserify-sign-4.2.1"
+        // {
+          dependencies = [
+            sources."inherits-2.0.4"
+            sources."readable-stream-3.6.0"
+          ];
+        })
       sources."browserify-zlib-0.2.0"
       sources."buffer-4.9.2"
       sources."buffer-xor-1.0.3"
@@ -1215,40 +1223,45 @@ in
       sources."console-browserify-1.2.0"
       sources."constants-browserify-1.0.0"
       sources."core-util-is-1.0.3"
-      (sources."create-ecdh-4.0.4" // {
-        dependencies = [
-          sources."bn.js-4.12.0"
-        ];
-      })
+      (sources."create-ecdh-4.0.4"
+        // {
+          dependencies = [
+            sources."bn.js-4.12.0"
+          ];
+        })
       sources."create-hash-1.2.0"
       sources."create-hmac-1.1.7"
       sources."crypto-browserify-3.12.0"
       sources."des.js-1.0.1"
-      (sources."diffie-hellman-5.0.3" // {
-        dependencies = [
-          sources."bn.js-4.12.0"
-        ];
-      })
+      (sources."diffie-hellman-5.0.3"
+        // {
+          dependencies = [
+            sources."bn.js-4.12.0"
+          ];
+        })
       sources."domain-browser-1.2.0"
-      (sources."elliptic-6.5.4" // {
-        dependencies = [
-          sources."bn.js-4.12.0"
-          sources."inherits-2.0.4"
-        ];
-      })
+      (sources."elliptic-6.5.4"
+        // {
+          dependencies = [
+            sources."bn.js-4.12.0"
+            sources."inherits-2.0.4"
+          ];
+        })
       sources."events-3.3.0"
       sources."evp_bytestokey-1.0.3"
-      (sources."hash-base-3.1.0" // {
-        dependencies = [
-          sources."inherits-2.0.4"
-          sources."readable-stream-3.6.0"
-        ];
-      })
-      (sources."hash.js-1.1.7" // {
-        dependencies = [
-          sources."inherits-2.0.4"
-        ];
-      })
+      (sources."hash-base-3.1.0"
+        // {
+          dependencies = [
+            sources."inherits-2.0.4"
+            sources."readable-stream-3.6.0"
+          ];
+        })
+      (sources."hash.js-1.1.7"
+        // {
+          dependencies = [
+            sources."inherits-2.0.4"
+          ];
+        })
       sources."hmac-drbg-1.0.1"
       sources."https-browserify-1.0.0"
       sources."ieee754-1.2.1"
@@ -1256,11 +1269,12 @@ in
       sources."isarray-1.0.0"
       sources."isexe-2.0.0"
       sources."md5.js-1.3.5"
-      (sources."miller-rabin-4.0.1" // {
-        dependencies = [
-          sources."bn.js-4.12.0"
-        ];
-      })
+      (sources."miller-rabin-4.0.1"
+        // {
+          dependencies = [
+            sources."bn.js-4.12.0"
+          ];
+        })
       sources."minimalistic-assert-1.0.1"
       sources."minimalistic-crypto-utils-1.0.1"
       sources."node-gyp-build-4.5.0"
@@ -1273,23 +1287,25 @@ in
       sources."pbkdf2-3.1.2"
       sources."process-0.11.10"
       sources."process-nextick-args-2.0.1"
-      (sources."public-encrypt-4.0.3" // {
-        dependencies = [
-          sources."bn.js-4.12.0"
-        ];
-      })
+      (sources."public-encrypt-4.0.3"
+        // {
+          dependencies = [
+            sources."bn.js-4.12.0"
+          ];
+        })
       sources."punycode-1.4.1"
       sources."querystring-0.2.0"
       sources."querystring-es3-0.2.1"
       sources."randombytes-2.1.0"
       sources."randomfill-1.0.4"
-      (sources."readable-stream-2.3.7" // {
-        dependencies = [
-          sources."inherits-2.0.4"
-          sources."safe-buffer-5.1.2"
-          sources."string_decoder-1.1.1"
-        ];
-      })
+      (sources."readable-stream-2.3.7"
+        // {
+          dependencies = [
+            sources."inherits-2.0.4"
+            sources."safe-buffer-5.1.2"
+            sources."string_decoder-1.1.1"
+          ];
+        })
       sources."readline-sync-1.4.10"
       sources."ripemd160-2.0.2"
       sources."safe-buffer-5.2.1"
@@ -1305,17 +1321,19 @@ in
       sources."timers-browserify-2.0.12"
       sources."to-arraybuffer-1.0.1"
       sources."tty-browserify-0.0.0"
-      (sources."url-0.11.0" // {
-        dependencies = [
-          sources."punycode-1.3.2"
-        ];
-      })
+      (sources."url-0.11.0"
+        // {
+          dependencies = [
+            sources."punycode-1.3.2"
+          ];
+        })
       sources."utf-8-validate-5.0.9"
-      (sources."util-0.11.1" // {
-        dependencies = [
-          sources."inherits-2.0.3"
-        ];
-      })
+      (sources."util-0.11.1"
+        // {
+          dependencies = [
+            sources."inherits-2.0.3"
+          ];
+        })
       sources."util-deprecate-1.0.2"
       sources."vm-browserify-1.1.2"
       sources."which-1.3.1"