summary refs log tree commit diff stats
path: root/user/overlays/extra-packages.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-04-25 17:22:23 +0200
committerAlan Pearce2024-04-25 17:22:23 +0200
commit08bddc4fc7219246aa17d0e03e27d4517462c8ad (patch)
treed47547bb45c650925c12a8fbd408449185054e14 /user/overlays/extra-packages.nix
parent798453ea55052c6af1752c1d6b1243e7c2591afd (diff)
downloadnixfiles-08bddc4fc7219246aa17d0e03e27d4517462c8ad.tar.lz
nixfiles-08bddc4fc7219246aa17d0e03e27d4517462c8ad.tar.zst
nixfiles-08bddc4fc7219246aa17d0e03e27d4517462c8ad.zip
override enchant with support for applespell on macOS
Diffstat (limited to 'user/overlays/extra-packages.nix')
-rw-r--r--user/overlays/extra-packages.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/user/overlays/extra-packages.nix b/user/overlays/extra-packages.nix
index 19490dca..ebe4fb0c 100644
--- a/user/overlays/extra-packages.nix
+++ b/user/overlays/extra-packages.nix
@@ -9,4 +9,14 @@ self: super: {
         }
     )
   );
+  enchant = super.enchant.overrideAttrs (old: {
+    configureFlags = old.configureFlags ++ [ "--without-hspell" ]
+      # builtins.filter (c: c != "--with-hspell") old.configureFlags
+      ++ self.lib.optional super.stdenv.isDarwin "--with-applespell"
+    ;
+    buildInputs =
+      builtins.filter (c: c.name != "hspell") old.buildInputs
+      ++ self.lib.optionals super.stdenv.isDarwin (with super.darwin.apple_sdk.frameworks; [ Cocoa ]);
+    propagatedBuildInputs = builtins.filter (c: c.name != "hspell") old.propagatedBuildInputs;
+  });
 }