summary refs log tree commit diff stats
path: root/user/nanopi.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-04-17 09:24:00 +0200
committerAlan Pearce2023-04-17 09:24:00 +0200
commit659df13a8a6ac848cc095987f33cc1020bd66af9 (patch)
treeac9cd9e5646cb93277bb419fcb91682cebd4a4ea /user/nanopi.nix
parentd3779759662e190b9ce7ccbd4620b956984e2b07 (diff)
downloadnixfiles-659df13a8a6ac848cc095987f33cc1020bd66af9.tar.lz
nixfiles-659df13a8a6ac848cc095987f33cc1020bd66af9.tar.zst
nixfiles-659df13a8a6ac848cc095987f33cc1020bd66af9.zip
Split NanoPi/other server config
Diffstat (limited to 'user/nanopi.nix')
-rw-r--r--user/nanopi.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/user/nanopi.nix b/user/nanopi.nix
new file mode 100644
index 00000000..130e985e
--- /dev/null
+++ b/user/nanopi.nix
@@ -0,0 +1,20 @@
+{ config
+, ...
+}:
+{
+  imports = [
+    ./settings/base.nix
+    ./settings/git.nix
+    ./settings/nix.nix
+    ./settings/nixos.nix
+    ./settings/music-management.nix
+    ./settings/zsh.nix
+  ];
+  config.programs.tabnine = false;
+  home = {
+    username = "alan";
+    sessionVariables.EDITOR = "${config.programs.neovim.finalPackage}/bin/nvim";
+    homeDirectory = "/home/alan";
+    stateVersion = "22.11";
+  };
+}