summary refs log tree commit diff stats
path: root/user/modules/tabnine.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-03-14 21:43:19 +0100
committerAlan Pearce2023-03-14 21:43:19 +0100
commit6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28 (patch)
tree7a126873d4a216438d835123843132d09eb2bfab /user/modules/tabnine.nix
parentfa2d41901d9fd10fd257c7ccc249ab29c5df2e33 (diff)
downloadnixfiles-6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28.tar.lz
nixfiles-6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28.tar.zst
nixfiles-6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28.zip
Re-format with nixpkgs-fmt
Diffstat (limited to 'user/modules/tabnine.nix')
-rw-r--r--user/modules/tabnine.nix38
1 files changed, 19 insertions, 19 deletions
diff --git a/user/modules/tabnine.nix b/user/modules/tabnine.nix
index 261176dc..7e38e0ec 100644
--- a/user/modules/tabnine.nix
+++ b/user/modules/tabnine.nix
@@ -1,26 +1,26 @@
-{
-  config,
-  lib,
-  pkgs,
-  ...
+{ config
+, lib
+, pkgs
+, ...
 }:
 with lib; let
   inherit (pkgs) stdenv;
   cfg = config.programs.tabnine;
   lspConfigFile = config:
     pkgs.runCommand "TabNine.toml"
-    {
-      buildInputs = [pkgs.remarshal];
-      preferLocalBuild = true;
-      allowSubstitutes = false;
-    }
-    ''
-      remarshal -if json -of toml \
-      < ${pkgs.writeText "config.json" (builtins.toJSON cfg.lspConfig)} \
-      | sed  -e 's/^\["\(.*\)"\]/[\1]/' \
-      > $out
-    '';
-in {
+      {
+        buildInputs = [ pkgs.remarshal ];
+        preferLocalBuild = true;
+        allowSubstitutes = false;
+      }
+      ''
+        remarshal -if json -of toml \
+        < ${pkgs.writeText "config.json" (builtins.toJSON cfg.lspConfig)} \
+        | sed  -e 's/^\["\(.*\)"\]/[\1]/' \
+        > $out
+      '';
+in
+{
   options.programs.tabnine = {
     enable = mkEnableOption "TabNine, Smart Compose for code.";
 
@@ -37,7 +37,7 @@ in {
 
     config = mkOption {
       type = types.attrs;
-      default = {};
+      default = { };
       description = ''
         TabNine configuration written to
         <filename>\${configDir}/tabnine_config.json</filename>
@@ -53,7 +53,7 @@ in {
 
     lspConfig = mkOption {
       type = types.attrs;
-      default = {};
+      default = { };
       description = ''
         LSP Server configuration written to
         <filename>\${configDir}/TabNine.toml</filename>