summary refs log tree commit diff stats
path: root/user/modules/i3.nix
diff options
context:
space:
mode:
authorAlan Pearce2019-10-08 21:44:57 +0200
committerAlan Pearce2019-10-08 21:44:57 +0200
commit0a50d682ec85bf023bebd68a3ca388001f0c0677 (patch)
tree3f725c5a36633ec5b59df37f156a03ee2a971656 /user/modules/i3.nix
parent40fd4964068d0b7628b6f699dab4aec200eadb0a (diff)
downloadnixfiles-0a50d682ec85bf023bebd68a3ca388001f0c0677.tar.lz
nixfiles-0a50d682ec85bf023bebd68a3ca388001f0c0677.tar.zst
nixfiles-0a50d682ec85bf023bebd68a3ca388001f0c0677.zip
mv modules settings
Diffstat (limited to 'user/modules/i3.nix')
-rw-r--r--user/modules/i3.nix149
1 files changed, 0 insertions, 149 deletions
diff --git a/user/modules/i3.nix b/user/modules/i3.nix
deleted file mode 100644
index d83ee2e7..00000000
--- a/user/modules/i3.nix
+++ /dev/null
@@ -1,149 +0,0 @@
-{ config, pkgs, lib, ... }:
-
-{
-  xdg.configFile.i3status = {
-    recursive = true;
-    source = ../i3/.config/i3status;
-  };
-  xsession.windowManager.i3 = let
-    mod = "Mod4";
-    mode_system = "System (l) lock, (e) logout, (s) suspend, (h) hibernate, (r) reboot, (Shift+s) shutdown";
-    locker = "${pkgs.xautolock}/bin/xautolock -locknow";
-  in
-  {
-    enable = true;
-    config = {
-      modifier = mod;
-      fonts = [ "Terminus 12px" ];
-      floating = {
-        criteria = [
-          { class = "Pinentry$"; }
-        ];
-      };
-      window = {
-        titlebar = false;
-      };
-      keybindings = {
-        "${mod}+Return" = "exec --no-startup-id xst";
-        # kill focused window
-        "${mod}+w" = "kill";
-        "${mod}+Shift+w" = "kill";
-
-        "--release ${mod}+Mod1+r" = "exec rofi -show run";
-        "--release ${mod}+Shift+semicolon" = "exec rofi-pass";
-        "--release ${mod}+space" = "exec \"rofi -show combi -combi-modi drun,window\"";
-
-        # change focus
-        "${mod}+h" = "focus left";
-        "${mod}+j" = "focus down";
-        "${mod}+k" = "focus up";
-        "${mod}+l" = "focus right";
-
-        "${mod}+1" = "workspace 1";
-        "${mod}+2" = "workspace 2";
-        "${mod}+3" = "workspace 3";
-        "${mod}+4" = "workspace 4";
-        "${mod}+5" = "workspace 5";
-        "${mod}+6" = "workspace 6";
-        "${mod}+7" = "workspace 7";
-        "${mod}+8" = "workspace 8";
-        "${mod}+9" = "workspace 9";
-        "${mod}+0" = "workspace 10";
-
-        # move focused window
-        "${mod}+Shift+h" = "move left";
-        "${mod}+Shift+j" = "move down";
-        "${mod}+Shift+k" = "move up";
-        "${mod}+Shift+l" = "move right";
-
-        "${mod}+Shift+1" = "move container to workspace 1";
-        "${mod}+Shift+2" = "move container to workspace 2";
-        "${mod}+Shift+3" = "move container to workspace 3";
-        "${mod}+Shift+4" = "move container to workspace 4";
-        "${mod}+Shift+5" = "move container to workspace 5";
-        "${mod}+Shift+6" = "move container to workspace 6";
-        "${mod}+Shift+7" = "move container to workspace 7";
-        "${mod}+Shift+8" = "move container to workspace 8";
-        "${mod}+Shift+9" = "move container to workspace 9";
-
-
-        # move workspace
-        "${mod}+Mod1+h" = "move workspace to output left";
-        "${mod}+Mod1+j" = "move workspace to output down";
-        "${mod}+Mod1+k" = "move workspace to output up";
-        "${mod}+Mod1+l" = "move workspace to output right";
-
-        # split in horizontal orientation
-        "${mod}+b" = "split h";
-
-        # split in vertical orientation
-        "${mod}+v" = "split v";
-
-        "${mod}+F11" = "fullscreen toggle";
-        "${mod}+f" = "fullscreen toggle";
-
-        # change container layout (stacked, tabbed, toggle split)
-        "${mod}+Shift+s" = "layout stacking";
-        "${mod}+Shift+t" = "layout tabbed";
-        "${mod}+Shift+v" = "layout toggle split";
-
-        # toggle tiling / floating
-        "${mod}+Shift+f" = "floating toggle";
-
-        # change focus between tiling / floating windows
-        "${mod}+Tab" = "focus mode_toggle";
-
-        # focus the parent container
-        "${mod}+a" = "focus parent";
-
-        # focus the child container
-        "${mod}+d" = "focus child";
-
-        "${mod}+Shift+c" = "reload";
-        "${mod}+Shift+p" = "restart";
-
-        "${mod}+Shift+r" = "mode resize";
-        "${mod}+Shift+o" = "exec ${locker}";
-        "${mod}+Pause" = "mode \"${mode_system}\"";
-        "${mod}+Escape" = "mode \"${mode_system}\"";
-        "${mod}+Shift+q" = "mode \"${mode_system}\"";
-      };
-
-      modes = {
-        resize = {
-          "h" = "resize shrink width 10 px or 10 ppt";
-          "j" = "resize grow height 10 px or 10 ppt";
-          "k" = "resize shrink height 10 px or 10 ppt";
-          "l" = "resize grow width 10 px or 10 ppt";
-
-          "Left" = "resize shrink width 10 px or 10 ppt";
-          "Down" = "resize grow height 10 px or 10 ppt";
-          "Up" = "resize shrink height 10 px or 10 ppt";
-          "Right" = "resize grow width 10 px or 10 ppt";
-
-          "Return" = "mode default";
-          "Escape" = "mode default";
-        };
-        "${mode_system}" = {
-          "l" = "exec --no-startup-id ${locker}, mode default";
-          "e" = "exec --no-startup-id i3-msg exit, mode default";
-          "s" = "exec --no-startup-id systemctl suspend, mode default";
-          "h" = "exec --no-startup-id systemctl hibernate, mode default";
-          "r" = "exec --no-startup-id systemctl reboot, mode default";
-          "Shift+s" = "exec --no-startup-id systemctl poweroff -i, mode default";
-          "Return" = "mode default";
-          "Escape" = "mode default";
-        };
-      };
-
-      bars = [
-        {
-          fonts = [ "Terminus 12px" ];
-          position = "top";
-          hiddenState = "show";
-          statusCommand = "${pkgs.i3status}/bin/i3status -c ~/.config/i3status/config";
-        }
-      ];
-    };
-  };
-}