summary refs log tree commit diff stats
path: root/user/modules/darwin.nix
diff options
context:
space:
mode:
authorAlan Pearce2019-10-05 19:43:32 +0200
committerAlan Pearce2019-10-05 22:57:38 +0200
commit5a179b4410a8b5c0e00f47c2b3798c8d9f62d8d1 (patch)
tree67505381af16001fa8c6150f89db874553dff0f8 /user/modules/darwin.nix
parent5d1e8a4c28b6f72b6e8d6f8df2794f2cce9bc75c (diff)
downloadnixfiles-5a179b4410a8b5c0e00f47c2b3798c8d9f62d8d1.tar.lz
nixfiles-5a179b4410a8b5c0e00f47c2b3798c8d9f62d8d1.tar.zst
nixfiles-5a179b4410a8b5c0e00f47c2b3798c8d9f62d8d1.zip
Move darwin configuration to user
Diffstat (limited to 'user/modules/darwin.nix')
-rw-r--r--user/modules/darwin.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/user/modules/darwin.nix b/user/modules/darwin.nix
new file mode 100644
index 00000000..e12a2ac4
--- /dev/null
+++ b/user/modules/darwin.nix
@@ -0,0 +1,44 @@
+{ config, pkgs, ... }:
+
+{
+  nixpkgs.overlays = [
+    (self: super: {
+      darwin-zsh-completions = super.runCommandNoCC "darwin-zsh-completions-0.0.0"
+        { preferLocalBuild = true; }
+        ''
+          mkdir -p $out/share/zsh/site-functions
+          cat <<-'EOF' > $out/share/zsh/site-functions/_darwin-rebuild
+          #compdef darwin-rebuild
+          #autoload
+          _nix-common-options
+          local -a _1st_arguments
+          _1st_arguments=(
+            'switch:Build, activate, and update the current generation'\
+            'build:Build without activating or updating the current generation'\
+            'check:Build and run the activation sanity checks'\
+            'changelog:Show most recent entries in the changelog'\
+          )
+          _arguments \
+            '--list-generations[Print a list of all generations in the active profile]'\
+            '--rollback[Roll back to the previous configuration]'\
+            {--switch-generation,-G}'[Activate specified generation]'\
+            '(--profile-name -p)'{--profile-name,-p}'[Profile to use to track current and previous system configurations]:Profile:_nix_profiles'\
+            '1:: :->subcmds' && return 0
+          case $state in
+            subcmds)
+              _describe -t commands 'darwin-rebuild subcommands' _1st_arguments
+            ;;
+          esac
+          EOF
+        '';
+      })
+  ];
+  home.packages = with pkgs; [
+      aspell
+      aspellDicts.en
+      darwin-zsh-completions
+  ];
+
+  # Use GPG from  GPGTools
+  programs.git.signing.gpgPath = "/usr/local/bin/gpg";
+}