summary refs log tree commit diff stats
path: root/user/modules/darwin.nix
diff options
context:
space:
mode:
authorAlan Pearce2019-10-08 21:44:57 +0200
committerAlan Pearce2019-10-08 21:44:57 +0200
commit0a50d682ec85bf023bebd68a3ca388001f0c0677 (patch)
tree3f725c5a36633ec5b59df37f156a03ee2a971656 /user/modules/darwin.nix
parent40fd4964068d0b7628b6f699dab4aec200eadb0a (diff)
downloadnixfiles-0a50d682ec85bf023bebd68a3ca388001f0c0677.tar.lz
nixfiles-0a50d682ec85bf023bebd68a3ca388001f0c0677.tar.zst
nixfiles-0a50d682ec85bf023bebd68a3ca388001f0c0677.zip
mv modules settings
Diffstat (limited to 'user/modules/darwin.nix')
-rw-r--r--user/modules/darwin.nix49
1 files changed, 0 insertions, 49 deletions
diff --git a/user/modules/darwin.nix b/user/modules/darwin.nix
deleted file mode 100644
index b3c4d7d7..00000000
--- a/user/modules/darwin.nix
+++ /dev/null
@@ -1,49 +0,0 @@
-{ config, pkgs, ... }:
-
-{
-  nixpkgs.overlays = [
-    (self: super: {
-      darwin-zsh-completions = super.runCommandNoCC "darwin-zsh-completions-0.0.0"
-        { preferLocalBuild = true; }
-        ''
-          mkdir -p $out/share/zsh/site-functions
-          cat <<-'EOF' > $out/share/zsh/site-functions/_darwin-rebuild
-          #compdef darwin-rebuild
-          #autoload
-          _nix-common-options
-          local -a _1st_arguments
-          _1st_arguments=(
-            'switch:Build, activate, and update the current generation'\
-            'build:Build without activating or updating the current generation'\
-            'check:Build and run the activation sanity checks'\
-            'changelog:Show most recent entries in the changelog'\
-          )
-          _arguments \
-            '--list-generations[Print a list of all generations in the active profile]'\
-            '--rollback[Roll back to the previous configuration]'\
-            {--switch-generation,-G}'[Activate specified generation]'\
-            '(--profile-name -p)'{--profile-name,-p}'[Profile to use to track current and previous system configurations]:Profile:_nix_profiles'\
-            '1:: :->subcmds' && return 0
-          case $state in
-            subcmds)
-              _describe -t commands 'darwin-rebuild subcommands' _1st_arguments
-            ;;
-          esac
-          EOF
-        '';
-      })
-  ];
-  home.packages = with pkgs; [
-      aspell
-      aspellDicts.en
-      darwin-zsh-completions
-  ];
-
-  programs.zsh.shellAliases = {
-    da = "darwin-rebuild";
-    das = "darwin-rebuild switch";
-  };
-
-  # Use GPG from  GPGTools
-  programs.git.signing.gpgPath = "/usr/local/bin/gpg";
-}