summary refs log tree commit diff stats
path: root/system/trillian.nix
diff options
context:
space:
mode:
authorAlan Pearce2019-10-04 16:14:13 +0200
committerAlan Pearce2019-10-04 16:31:27 +0200
commit5d859b419e1e1a850cd160e05d98bda3fd9883ea (patch)
treedb18b88172fe344dcb84e07d158c2d7c61f6005a /system/trillian.nix
parenta6008a0432b90faa49ffaa76267d3af98adac54a (diff)
downloadnixfiles-5d859b419e1e1a850cd160e05d98bda3fd9883ea.tar.lz
nixfiles-5d859b419e1e1a850cd160e05d98bda3fd9883ea.tar.zst
nixfiles-5d859b419e1e1a850cd160e05d98bda3fd9883ea.zip
Move Emacs to user configuration
Diffstat (limited to 'system/trillian.nix')
-rw-r--r--system/trillian.nix13
1 files changed, 0 insertions, 13 deletions
diff --git a/system/trillian.nix b/system/trillian.nix
index 1f4ce67e..8c1f0deb 100644
--- a/system/trillian.nix
+++ b/system/trillian.nix
@@ -1,10 +1,5 @@
 { config, pkgs, ... }:
 
-let emacsPackage = import ./packages/emacs.nix {
-  pkgs = pkgs.unstable;
-  emacs = pkgs.unstable.emacs;
-};
-in
 {
   imports = [
     ./private/default.nix
@@ -39,7 +34,6 @@ in
   environment.systemPackages = with pkgs;
     [
       mosh
-      emacsPackage
       aspell
       aspellDicts.en
       darwin-zsh-completions
@@ -75,13 +69,6 @@ in
     };
   };
 
-  # launchd.user.agents.emacs-daemon = {
-  #   command = "${emacsPackage}/bin/emacs --daemon";
-  #   serviceConfig = {
-  #     KeepAlive = true;
-  #   };
-  # };
-  #
   nix.gc = {
     automatic = true;
     options = "--max-freed $((25 * 1024**3 - 1024 * $(df -P -k /nix/store | tail -n 1 | awk '{ print $4 }')))";