summary refs log tree commit diff stats
path: root/system/trillian.nix
diff options
context:
space:
mode:
authorAlan Pearce2019-10-05 19:43:32 +0200
committerAlan Pearce2019-10-05 22:57:38 +0200
commit5a179b4410a8b5c0e00f47c2b3798c8d9f62d8d1 (patch)
tree67505381af16001fa8c6150f89db874553dff0f8 /system/trillian.nix
parent5d1e8a4c28b6f72b6e8d6f8df2794f2cce9bc75c (diff)
downloadnixfiles-5a179b4410a8b5c0e00f47c2b3798c8d9f62d8d1.tar.lz
nixfiles-5a179b4410a8b5c0e00f47c2b3798c8d9f62d8d1.tar.zst
nixfiles-5a179b4410a8b5c0e00f47c2b3798c8d9f62d8d1.zip
Move darwin configuration to user
Diffstat (limited to 'system/trillian.nix')
-rw-r--r--system/trillian.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/system/trillian.nix b/system/trillian.nix
index 3fdd775e..73093c99 100644
--- a/system/trillian.nix
+++ b/system/trillian.nix
@@ -21,16 +21,6 @@
     ];
   };
 
-  # List packages installed in system profile. To search by name, run:
-  # $ nix-env -qaP | grep  wget
-  environment.systemPackages = with pkgs;
-    [
-      mosh
-      aspell
-      aspellDicts.en
-      darwin-zsh-completions
-    ];
-
   # Use a custom configuration.nix location.
   # $ darwin-rebuild switch -I darwin-config=$HOME/.config/nixpkgs/darwin/configuration.nix
   # environment.darwinConfig = "$HOME/.config/nixpkgs/darwin/configuration.nix";
@@ -44,11 +34,6 @@
 
   # programs.nix-index.enable = true;
 
-  programs.vim = {
-    enable = true;
-    enableSensible = true;
-  };
-
   programs.zsh.enable = true;
   programs.zsh.enableBashCompletion = true;
 
@@ -68,38 +53,6 @@
   nix.daemonNiceLevel = 10;
   nix.daemonIONice = true;
 
-  nixpkgs.overlays = [
-    (self: super: {
-      darwin-zsh-completions = super.runCommandNoCC "darwin-zsh-completions-0.0.0"
-        { preferLocalBuild = true; }
-        ''
-          mkdir -p $out/share/zsh/site-functions
-          cat <<-'EOF' > $out/share/zsh/site-functions/_darwin-rebuild
-          #compdef darwin-rebuild
-          #autoload
-          _nix-common-options
-          local -a _1st_arguments
-          _1st_arguments=(
-            'switch:Build, activate, and update the current generation'\
-            'build:Build without activating or updating the current generation'\
-            'check:Build and run the activation sanity checks'\
-            'changelog:Show most recent entries in the changelog'\
-          )
-          _arguments \
-            '--list-generations[Print a list of all generations in the active profile]'\
-            '--rollback[Roll back to the previous configuration]'\
-            {--switch-generation,-G}'[Activate specified generation]'\
-            '(--profile-name -p)'{--profile-name,-p}'[Profile to use to track current and previous system configurations]:Profile:_nix_profiles'\
-            '1:: :->subcmds' && return 0
-          case $state in
-            subcmds)
-              _describe -t commands 'darwin-rebuild subcommands' _1st_arguments
-            ;;
-          esac
-          EOF
-        '';
-      })
-  ];
   # Used for backwards compatibility, please read the changelog before changing.
   # $ darwin-rebuild changelog
   system.stateVersion = 4;