summary refs log tree commit diff stats
path: root/system/settings/user-interface.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-03-14 21:43:19 +0100
committerAlan Pearce2023-03-14 21:43:19 +0100
commit6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28 (patch)
tree7a126873d4a216438d835123843132d09eb2bfab /system/settings/user-interface.nix
parentfa2d41901d9fd10fd257c7ccc249ab29c5df2e33 (diff)
downloadnixfiles-6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28.tar.lz
nixfiles-6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28.tar.zst
nixfiles-6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28.zip
Re-format with nixpkgs-fmt
Diffstat (limited to 'system/settings/user-interface.nix')
-rw-r--r--system/settings/user-interface.nix17
1 files changed, 8 insertions, 9 deletions
diff --git a/system/settings/user-interface.nix b/system/settings/user-interface.nix
index 577ecdc1..8dca1e10 100644
--- a/system/settings/user-interface.nix
+++ b/system/settings/user-interface.nix
@@ -1,14 +1,13 @@
-{
-  config,
-  pkgs,
-  lib,
-  makeDesktopItem,
-  ...
+{ config
+, pkgs
+, lib
+, makeDesktopItem
+, ...
 }: {
   documentation.info.enable = true;
   nixpkgs.config.firefox.enableOfficialBranding = true;
 
-  environment.pathsToLink = ["/share/zsh"];
+  environment.pathsToLink = [ "/share/zsh" ];
 
   environment.systemPackages = with pkgs; [
     aria2
@@ -33,7 +32,7 @@
   services.devmon.enable = true;
 
   systemd.user.services.trash-clean = {
-    path = with pkgs; [trash-cli];
+    path = with pkgs; [ trash-cli ];
     description = "Remove old files from FreeDesktop.org trash";
 
     serviceConfig = {
@@ -42,7 +41,7 @@
     script = "trash-empty 30";
   };
   systemd.user.timers.trash-clean = {
-    wantedBy = ["default.target"];
+    wantedBy = [ "default.target" ];
     timerConfig = {
       OnCalendar = "weekly";
       Persistent = true;