summary refs log tree commit diff stats
path: root/system/settings/services/samba.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-03-14 21:43:19 +0100
committerAlan Pearce2023-03-14 21:43:19 +0100
commit6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28 (patch)
tree7a126873d4a216438d835123843132d09eb2bfab /system/settings/services/samba.nix
parentfa2d41901d9fd10fd257c7ccc249ab29c5df2e33 (diff)
downloadnixfiles-6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28.tar.lz
nixfiles-6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28.tar.zst
nixfiles-6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28.zip
Re-format with nixpkgs-fmt
Diffstat (limited to 'system/settings/services/samba.nix')
-rw-r--r--system/settings/services/samba.nix17
1 files changed, 9 insertions, 8 deletions
diff --git a/system/settings/services/samba.nix b/system/settings/services/samba.nix
index 729a6756..ae6c6f5a 100644
--- a/system/settings/services/samba.nix
+++ b/system/settings/services/samba.nix
@@ -1,16 +1,17 @@
-{
-  config,
-  pkgs,
-  ...
-}: let
+{ config
+, pkgs
+, ...
+}:
+let
   workgroup = "WORKGROUP";
-in {
+in
+{
   services.samba-wsdd = {
     inherit workgroup;
     enable = true;
   };
-  networking.firewall.allowedTCPPorts = [5357];
-  networking.firewall.allowedUDPPorts = [3702];
+  networking.firewall.allowedTCPPorts = [ 5357 ];
+  networking.firewall.allowedUDPPorts = [ 3702 ];
 
   services.samba = {
     enable = true;