summary refs log tree commit diff stats
path: root/system/settings/hardware/laptop.nix
diff options
context:
space:
mode:
authorAlan Pearce2019-11-13 16:29:18 +0100
committerAlan Pearce2019-11-13 16:29:29 +0100
commit60573b583d1c34e9e8f4425c00b1524c484567b3 (patch)
tree5e0278ad6fc10918043e3937f0a1ba939439a1fb /system/settings/hardware/laptop.nix
parenta12b6a483de7675261456e159d653f90c7920828 (diff)
downloadnixfiles-60573b583d1c34e9e8f4425c00b1524c484567b3.tar.lz
nixfiles-60573b583d1c34e9e8f4425c00b1524c484567b3.tar.zst
nixfiles-60573b583d1c34e9e8f4425c00b1524c484567b3.zip
laptop: fix autorandr failing at startup
Diffstat (limited to 'system/settings/hardware/laptop.nix')
-rw-r--r--system/settings/hardware/laptop.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/system/settings/hardware/laptop.nix b/system/settings/hardware/laptop.nix
index abbb2ebb..aca900a6 100644
--- a/system/settings/hardware/laptop.nix
+++ b/system/settings/hardware/laptop.nix
@@ -29,7 +29,12 @@
 
   programs.light.enable = true;
 
-  services.autorandr.enable = true;
+  services.autorandr = {
+    enable = true;
+    defaultTarget = "common";
+  };
+  systemd.services.autorandr.wantedBy = [ "graphical.target" ];
+
   environment.etc.autorandr = {
     enable = true;
     source = ../../autorandr;