summary refs log tree commit diff stats
path: root/system/settings/hardware/bluetooth-audio.nix
diff options
context:
space:
mode:
authorAlan Pearce2021-01-12 17:01:45 +0100
committerAlan Pearce2021-01-12 17:01:45 +0100
commit82eac6549fe01ecd4b8aec799f1dba37eb253ecd (patch)
treed452aa54421c1ec547effc951c4f71f3b6f382f1 /system/settings/hardware/bluetooth-audio.nix
parent2ad5213fbb065d59e8435669f71b054bd9fd52f5 (diff)
downloadnixfiles-82eac6549fe01ecd4b8aec799f1dba37eb253ecd.tar.lz
nixfiles-82eac6549fe01ecd4b8aec799f1dba37eb253ecd.tar.zst
nixfiles-82eac6549fe01ecd4b8aec799f1dba37eb253ecd.zip
Extract bluetooth settings from laptop module
Diffstat (limited to 'system/settings/hardware/bluetooth-audio.nix')
-rw-r--r--system/settings/hardware/bluetooth-audio.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/system/settings/hardware/bluetooth-audio.nix b/system/settings/hardware/bluetooth-audio.nix
new file mode 100644
index 00000000..69f46984
--- /dev/null
+++ b/system/settings/hardware/bluetooth-audio.nix
@@ -0,0 +1,14 @@
+{ config, pkgs, ... }:
+
+{
+  hardware = {
+    bluetooth = {
+      package = pkgs.bluezFull;
+    };
+    pulseaudio = {
+      extraModules = with pkgs; [
+        pulseaudio-modules-bt
+      ];
+    };
+  };
+}