summary refs log tree commit diff stats
path: root/system/settings/darwin.nix
diff options
context:
space:
mode:
authorAlan Pearce2020-12-31 22:00:06 +0100
committerAlan Pearce2021-01-12 21:03:31 +0100
commit60740689e4575c353248c1aad25f7db577ce8f71 (patch)
tree2519357f02fbc6de75a9c7eeaaae6deb5231495c /system/settings/darwin.nix
parent4d230ecf19a7709d8fabdd1cae155057215576d0 (diff)
downloadnixfiles-60740689e4575c353248c1aad25f7db577ce8f71.tar.lz
nixfiles-60740689e4575c353248c1aad25f7db577ce8f71.tar.zst
nixfiles-60740689e4575c353248c1aad25f7db577ce8f71.zip
Move common nix-darwin config to darwin.nix
Diffstat (limited to 'system/settings/darwin.nix')
-rw-r--r--system/settings/darwin.nix16
1 files changed, 15 insertions, 1 deletions
diff --git a/system/settings/darwin.nix b/system/settings/darwin.nix
index 6143625b..629eff16 100644
--- a/system/settings/darwin.nix
+++ b/system/settings/darwin.nix
@@ -1,10 +1,24 @@
-{ config, pkgs, ... }:
+{ config, pkgs, lib, ... }:
 
 {
   services.nix-daemon = {
     enable = true;
     enableSocketListener = true;
   };
+  nix = {
+    buildCores = lib.mkDefault 0;
+    daemonIONice = true;
+    daemonNiceLevel = 10;
+    gc = {
+      automatic = true;
+      user = "alan";
+      options = "--max-freed $((25 * 1024**3 - 1024 * $(df -P -k /nix/store | tail -n 1 | awk '{ print $4 }')))";
+    };
+  };
+
+  nixpkgs.config = {
+    allowUnfree = true;
+  };
 
   programs.zsh = {
     enable = true;