summary refs log tree commit diff stats
path: root/system/settings/base.nix
diff options
context:
space:
mode:
authorAlan Pearce2019-11-12 19:30:35 +0100
committerAlan Pearce2019-11-20 11:14:15 +0100
commit749f4be1ef9b115c97fa717cc6068ab342c7650c (patch)
tree1a4041001578e0cb03c1dfd021c1082b71c2a816 /system/settings/base.nix
parent1078600d993baaf585d91a476f0d03c992817518 (diff)
downloadnixfiles-749f4be1ef9b115c97fa717cc6068ab342c7650c.tar.lz
nixfiles-749f4be1ef9b115c97fa717cc6068ab342c7650c.tar.zst
nixfiles-749f4be1ef9b115c97fa717cc6068ab342c7650c.zip
Configure nextdns usage via module
Diffstat (limited to 'system/settings/base.nix')
-rw-r--r--system/settings/base.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/system/settings/base.nix b/system/settings/base.nix
index 9e94a5a2..8f0c32b2 100644
--- a/system/settings/base.nix
+++ b/system/settings/base.nix
@@ -1,11 +1,21 @@
 { config, pkgs, ... }:
 
-{ boot.loader.timeout = 1;
+{
+  imports = [
+    ../modules/nextdns.nix
+  ];
+  boot.loader.timeout = 1;
 
   environment.systemPackages = with pkgs; [
     nix-index
   ];
 
+  networking.nextdns = {
+    enable = true;
+    configID = "abd6e5";
+    identifyDevice = true;
+  };
+
   networking.extraHosts = ''
     127.0.0.1 ${config.networking.hostName}
     ::1 ${config.networking.hostName}