summary refs log tree commit diff stats
path: root/system/prefect.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-03-14 21:43:19 +0100
committerAlan Pearce2023-03-14 21:43:19 +0100
commit6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28 (patch)
tree7a126873d4a216438d835123843132d09eb2bfab /system/prefect.nix
parentfa2d41901d9fd10fd257c7ccc249ab29c5df2e33 (diff)
downloadnixfiles-6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28.tar.lz
nixfiles-6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28.tar.zst
nixfiles-6db9eaad8e78f882ae44a28edcc4d11d2ffd5e28.zip
Re-format with nixpkgs-fmt
Diffstat (limited to 'system/prefect.nix')
-rw-r--r--system/prefect.nix29
1 files changed, 14 insertions, 15 deletions
diff --git a/system/prefect.nix b/system/prefect.nix
index 7891110a..ea65197a 100644
--- a/system/prefect.nix
+++ b/system/prefect.nix
@@ -1,10 +1,9 @@
-{
-  config,
-  pkgs,
-  nixpkgs,
-  nixpkgs-unstable,
-  nixos-hardware,
-  ...
+{ config
+, pkgs
+, nixpkgs
+, nixpkgs-unstable
+, nixos-hardware
+, ...
 }: {
   imports = [
     (nixos-hardware + "/common/pc/ssd")
@@ -61,15 +60,15 @@
     zenpower
   ];
 
-  boot.initrd.availableKernelModules = ["nvme" "xhci_pci" "ahci" "usbhid" "sd_mod"];
-  boot.initrd.kernelModules = [];
-  boot.kernelModules = ["kvm-amd"];
+  boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "ahci" "usbhid" "sd_mod" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ "kvm-amd" ];
 
   fileSystems = {
     "/" = {
       device = "/dev/disk/by-partlabel/nixos-root";
       fsType = "f2fs";
-      options = ["atgc" "gc_merge" "lazytime" "nodiscard"];
+      options = [ "atgc" "gc_merge" "lazytime" "nodiscard" ];
     };
 
     "/boot" = {
@@ -80,25 +79,25 @@
     "/home" = {
       device = "/dev/disk/by-partlabel/home";
       fsType = "ext4";
-      options = ["lazytime" "nodiscard"];
+      options = [ "lazytime" "nodiscard" ];
     };
 
     "/mnt/data" = {
       device = "/dev/disk/by-partlabel/data";
       fsType = "ntfs3";
-      options = ["uid=1000" "gid=100" "x-systemd-automount" "nofail"];
+      options = [ "uid=1000" "gid=100" "x-systemd-automount" "nofail" ];
     };
 
     "/mnt/games" = {
       device = "/dev/disk/by-partlabel/games";
       fsType = "ntfs3";
-      options = ["uid=1000" "gid=100" "x-systemd-automount" "nofail"];
+      options = [ "uid=1000" "gid=100" "x-systemd-automount" "nofail" ];
     };
 
     "/mnt/windows" = {
       device = "/dev/disk/by-partlabel/windows";
       fsType = "ntfs3";
-      options = ["x-systemd-automount" "nofail"];
+      options = [ "x-systemd-automount" "nofail" ];
     };
   };