summary refs log tree commit diff stats
path: root/system/prefect.nix
diff options
context:
space:
mode:
authorAlan Pearce2022-10-16 23:49:18 +0200
committerAlan Pearce2022-10-16 23:56:07 +0200
commit05dd85210e465caa44ef7254f2781b2d12ba2882 (patch)
tree85ccc720e339dd5ca8d7eb3ce6a3488c78675235 /system/prefect.nix
parent472dbbdbb246cf3d8ce3a5c3c6cefaa07b7589df (diff)
downloadnixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.lz
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.zst
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.zip
Reformat files with alejandra
Diffstat (limited to 'system/prefect.nix')
-rw-r--r--system/prefect.nix35
1 files changed, 23 insertions, 12 deletions
diff --git a/system/prefect.nix b/system/prefect.nix
index b4eb6f34..8c80ff6f 100644
--- a/system/prefect.nix
+++ b/system/prefect.nix
@@ -1,6 +1,12 @@
-{ config, pkgs, nixpkgs, nixpkgs-unstable, nixos-hardware, ... }:
-
-{ imports = [
+{
+  config,
+  pkgs,
+  nixpkgs,
+  nixpkgs-unstable,
+  nixos-hardware,
+  ...
+}: {
+  imports = [
     (nixos-hardware + "/common/pc/ssd")
     (nixos-hardware + "/common/cpu/amd")
 
@@ -56,15 +62,15 @@
     zenpower
   ];
 
-  boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "ahci" "usbhid" "sd_mod" ];
-  boot.initrd.kernelModules = [ ];
-  boot.kernelModules = [ "kvm-amd" ];
+  boot.initrd.availableKernelModules = ["nvme" "xhci_pci" "ahci" "usbhid" "sd_mod"];
+  boot.initrd.kernelModules = [];
+  boot.kernelModules = ["kvm-amd"];
 
   fileSystems = {
     "/" = {
       device = "/dev/disk/by-partlabel/nixos-root";
       fsType = "f2fs";
-      options = [ "atgc" "gc_merge" "lazytime" "nodiscard" ];
+      options = ["atgc" "gc_merge" "lazytime" "nodiscard"];
     };
 
     "/boot" = {
@@ -75,29 +81,34 @@
     "/home" = {
       device = "/dev/disk/by-partlabel/home";
       fsType = "ext4";
-      options = [ "lazytime" "nodiscard" ];
+      options = ["lazytime" "nodiscard"];
     };
 
     "/mnt/data" = {
       device = "/dev/disk/by-partlabel/data";
       fsType = "ntfs3";
-      options = [ "uid=1000" "gid=100" "x-systemd-automount" "nofail" ];
+      options = ["uid=1000" "gid=100" "x-systemd-automount" "nofail"];
     };
 
     "/mnt/games" = {
       device = "/dev/disk/by-partlabel/games";
       fsType = "ntfs3";
-      options = [ "uid=1000" "gid=100" "x-systemd-automount" "nofail" ];
+      options = ["uid=1000" "gid=100" "x-systemd-automount" "nofail"];
     };
 
     "/mnt/windows" = {
       device = "/dev/disk/by-partlabel/windows";
       fsType = "ntfs3";
-      options = [ "x-systemd-automount" "nofail" ];
+      options = ["x-systemd-automount" "nofail"];
     };
   };
 
-  swapDevices = [ { label = "swap"; discardPolicy = "once"; } ];
+  swapDevices = [
+    {
+      label = "swap";
+      discardPolicy = "once";
+    }
+  ];
 
   services.xserver = {
     xautolock.enable = pkgs.lib.mkForce false;