summary refs log tree commit diff stats
path: root/system/nanopi.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-31 00:23:20 +0200
committerAlan Pearce2024-05-31 00:23:20 +0200
commit822aa69ea26feb343432c96f3d7a930ae4bdb69d (patch)
treec803668c6f0d33da09ea3d81f39581e539e2e1a8 /system/nanopi.nix
parent84b93c8b1c03379dcf3f76ddd29db4dcbb7cffcd (diff)
downloadnixfiles-822aa69ea26feb343432c96f3d7a930ae4bdb69d.tar.lz
nixfiles-822aa69ea26feb343432c96f3d7a930ae4bdb69d.tar.zst
nixfiles-822aa69ea26feb343432c96f3d7a930ae4bdb69d.zip
nanopi: fix interface-name- based DNS resolution
Diffstat (limited to 'system/nanopi.nix')
-rwxr-xr-xsystem/nanopi.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/system/nanopi.nix b/system/nanopi.nix
index 18e9a647..a95d9dc0 100755
--- a/system/nanopi.nix
+++ b/system/nanopi.nix
@@ -486,10 +486,10 @@ in
         "homeassistant,ha"
       ];
       interface-name = [
-        "nanopi,bridge0"
-        "wan,wan0"
-        "wlan,wlan0"
-        "wwan,wwan0"
+        "nanopi.${domain},bridge0"
+        "wan.${domain},wan0"
+        "wlan.${domain},wlan0"
+        "wwan.${domain},wwan0"
       ];
       interface = [
         "lo"