summary refs log tree commit diff stats
path: root/system/nanopi.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-28 10:19:07 +0200
committerAlan Pearce2024-05-28 10:19:07 +0200
commit68de0136c965c6549e39f7ca6d83be9f781aca6a (patch)
treeab2f7450f8be3790fd28b827d8755e106da84f1d /system/nanopi.nix
parenta1edb7d39b6561a493c151a47b24cddf5378f1f9 (diff)
downloadnixfiles-68de0136c965c6549e39f7ca6d83be9f781aca6a.tar.lz
nixfiles-68de0136c965c6549e39f7ca6d83be9f781aca6a.tar.zst
nixfiles-68de0136c965c6549e39f7ca6d83be9f781aca6a.zip
nanopi: disable SSH logins with passwords
Diffstat (limited to 'system/nanopi.nix')
-rwxr-xr-xsystem/nanopi.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/system/nanopi.nix b/system/nanopi.nix
index 1fe720d7..4c91c787 100755
--- a/system/nanopi.nix
+++ b/system/nanopi.nix
@@ -200,6 +200,10 @@ in
     enable = true;
     openFirewall = true;
     startWhenNeeded = false;
+    settings = {
+      PasswordAuthentication = false;
+      KbdInteractiveAuthentication = false;
+    };
   };
   programs.mosh.enable = true;
   services.sshguard = {