summary refs log tree commit diff stats
path: root/system/nanopi.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-06-08 20:47:46 +0200
committerAlan Pearce2024-06-09 18:28:22 +0200
commit1db2e8348d166e78798f3bd20669ee2f7b92e368 (patch)
tree6f0bf84112d75b3dda2096840a8059709184f042 /system/nanopi.nix
parentc46e0e72210f0b4e977dab75ceccae51969523ae (diff)
downloadnixfiles-1db2e8348d166e78798f3bd20669ee2f7b92e368.tar.lz
nixfiles-1db2e8348d166e78798f3bd20669ee2f7b92e368.tar.zst
nixfiles-1db2e8348d166e78798f3bd20669ee2f7b92e368.zip
nanopi: update network setting structure (logical no-op)
Diffstat (limited to 'system/nanopi.nix')
-rwxr-xr-xsystem/nanopi.nix60
1 files changed, 24 insertions, 36 deletions
diff --git a/system/nanopi.nix b/system/nanopi.nix
index 5004ecd8..105c0566 100755
--- a/system/nanopi.nix
+++ b/system/nanopi.nix
@@ -310,10 +310,8 @@ in
         ];
         addresses = [
           {
-            addressConfig = {
-              Address = "fe80::1/64";
-              Scope = "link";
-            };
+            Address = "fe80::1/64";
+            Scope = "link";
           }
         ];
         networkConfig = {
@@ -347,13 +345,11 @@ in
         ipv6AcceptRAConfig.UseDNS = false;
         routes = [
           {
-            routeConfig = {
-              Gateway = "_dhcp4";
-              Metric = 2048;
-              QuickAck = true;
-              InitialCongestionWindow = 30;
-              InitialAdvertisedReceiveWindow = 30;
-            };
+            Gateway = "_dhcp4";
+            Metric = 2048;
+            QuickAck = true;
+            InitialCongestionWindow = 30;
+            InitialAdvertisedReceiveWindow = 30;
           }
         ];
         cakeConfig = {
@@ -394,30 +390,24 @@ in
         };
         addresses = [
           {
-            addressConfig = {
-              Address = "192.168.100.10/24";
-              # Peer = "192.168.100.1/32";
-              Label = "wan0:0";
-              # Scope = "link";
-            };
+            Address = "192.168.100.10/24";
+            # Peer = "192.168.100.1/32";
+            Label = "wan0:0";
+            # Scope = "link";
           }
         ];
         routes = [
           {
-            routeConfig = {
-              Gateway = "_dhcp4";
-              QuickAck = true;
-              InitialCongestionWindow = 30;
-              InitialAdvertisedReceiveWindow = 30;
-            };
+            Gateway = "_dhcp4";
+            QuickAck = true;
+            InitialCongestionWindow = 30;
+            InitialAdvertisedReceiveWindow = 30;
           }
           {
-            routeConfig = {
-              Gateway = "_ipv6ra";
-              QuickAck = true;
-              InitialCongestionWindow = 30;
-              InitialAdvertisedReceiveWindow = 30;
-            };
+            Gateway = "_ipv6ra";
+            QuickAck = true;
+            InitialCongestionWindow = 30;
+            InitialAdvertisedReceiveWindow = 30;
           }
         ];
         cakeConfig = {
@@ -445,13 +435,11 @@ in
         };
         routes = [
           {
-            routeConfig = {
-              Metric = 2048;
-              Gateway = "_dhcp4";
-              QuickAck = true;
-              InitialCongestionWindow = 30;
-              InitialAdvertisedReceiveWindow = 30;
-            };
+            Metric = 2048;
+            Gateway = "_dhcp4";
+            QuickAck = true;
+            InitialCongestionWindow = 30;
+            InitialAdvertisedReceiveWindow = 30;
           }
         ];
         cakeConfig = {