summary refs log tree commit diff stats
path: root/system/nano.nix
diff options
context:
space:
mode:
authorAlan Pearce2025-02-13 21:46:30 +0100
committerAlan Pearce2025-02-13 21:46:30 +0100
commit45b5b9a88244fd16936adcb158cb66673086a685 (patch)
tree09f1b8e169a4dec3814cfe5886e91877ae0c00a0 /system/nano.nix
parent1402361310f86dd85190cacb3be3d18bf8dc7705 (diff)
downloadnixfiles-45b5b9a88244fd16936adcb158cb66673086a685.tar.lz
nixfiles-45b5b9a88244fd16936adcb158cb66673086a685.tar.zst
nixfiles-45b5b9a88244fd16936adcb158cb66673086a685.zip
nano: add useful settings/packages for routing
Diffstat (limited to 'system/nano.nix')
-rw-r--r--system/nano.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/system/nano.nix b/system/nano.nix
index bda0b0d4..5de5d887 100644
--- a/system/nano.nix
+++ b/system/nano.nix
@@ -52,6 +52,13 @@ in
     "tcp_lp"
   ];
   boot.kernel.sysctl = {
+    "net.ipv6.conf.all.accept_ra" = 0;
+    "net.ipv6.conf.all.autoconf" = 0;
+    "net.ipv6.conf.all.use_tempaddr" = 0;
+
+    "net.ipv6.conf.${wan}.accept_ra" = 2;
+    "net.ipv6.conf.${wan}.autoconf" = 1;
+
     "net.ipv4.tcp_slow_start_after_idle" = 0;
     "net.ipv4.tcp_ecn" = 1;
     "net.ipv4.tcp_fastopen" = "0x3";
@@ -296,6 +303,9 @@ in
     tree
     lsof
     knot-dns
+    ethtool
+    tcpdump
+    conntrack-tools
   ];
 
   programs.fish.enable = true;